Beginner Question: content tree problems in ui

Hi,

i just installed a new neos instance, simply following the tutorial in the docs ( Code Q Neos-Skeleton).

Installation went fine, system is up and running, i am logged in in the backend.

Now, when i start to add some “Standard Pages”, the pages get created ok, and i can publish them to live o.k.

but the content tree on the left side in the ui is quite shaky, i have to constantly click on the refresh button, otherwise only one of the page nodes stays visible:

for example:

  • click refresh: three page nodes are visible.
  • click on a page node: editor view changes to correct page, but the content tree also changes and the other page nodes in the treenodes on the left side disappear.
  • click on refresh in the node browser: page nodes are back.

this behaviour is driving me crazy.

is this a known problem, what can i do to get a reliable content tree view?

specs of the installation:

  • working on mac m1 laptop
  • installed php 8.0 and composer
  • using postgres db.
  • installation: just as documented in your neos tutorial with the codeq skeleton.

Thanks,
Max

Hi Max,

welcome to the community!
Sounds very unusual, I’m not aware of that issue.

So just to fully understand, you have issues with the page tree or the content tree, or both?

I assume if you did a fresh install you run Neos 7.3.1, can you verify that?

Regards
Seb

Hi,

sorry, i should’ve been more precise in my description of the issue:

it’s the page tree i am talking about, not the content tree.
Admin > Package Management shows: noes/neos 7.3.1 and neos/neos-ui 7.3.1.

two things i can add to my experience:

  1. adding a new page: and i get the “shaky” page tree.
    stopping neos and flushing caches: then the page tree is o.k. until i add another page.

  2. it’s happening not only on my mac, tried it yesterday on a linux machine: same behavior. also tried with different browsers: safari, firefox, chromium. no difference.

maybe it’s some setting in the codeq skeleton, because that’s what i am using, following strictly the tutorial in the docs.

Thanks,
Max

Ok thx, can’t reproduce this issue in my Neos 7.3.

Maybe you can also provide a short screencast which might make it easier for us to reproduce / understand.

Do you also have a stock Neos 7.3 with the Demo site setup where you can compare the behaviour?
Then we know if its the skeleton or some general ui issue.

Short screencast: neos_skeleton

will try to setup a stock neos 7.3.1 with the demo site in the evening or tomorrow.

thanks,
max

Did a quick install now without the codeq skeleton:

composer create-project neos/neos-base-distribution neos-example

Install and import of Neos.Demo worked, and here i am NOT getting this weird Document Tree behavior. Can add pages and the document tree is working as expected.

Max

is this the same issue? Slack

Hi guys,

i just opened an issue in the repo of the neos skeleton project of codeq, maybe they have an idea.

Since the problem doesn’t seem to happen, when working without the codeq skeleton, i will move on with my neos tests by just starting a project from scratch, without any template. should be better for the learning experience anyways.

thanks for your feedback,

Max

1 Like

Thanks for your feedback. I do not think that’s a bug of the skeleton, since the endpoint is not in any way manipulated.

I could reproduce the issue too, this is my setup:

  • Linux
  • Neos run with flow server:run
  • MariaDB in a Docker container
  • Neos 7.x or also 8.x

Creating a site from scratch using the site kickstarter the issue did not appear.
Using the CodeQ sekeleton site package, the same issue could be reproduced.

Till now I could not figure out yet where the issue is. Interesting fact is, that after flushing the cache the issue disappears and it appears again if I create other new pages in the document tree.

So my assumption is that it has to do something with the Caching config…