Blocked:mixed-content Issue [Solved]


(pawan kumar) #1

Since my server is running on https, But a resource like static CSS,js they are being called as HTTP protocol.
Showing Blocked-Mixed-Content issue

Do I need to make any changes?


(Sebastian Helzle) #2

Did you setup a domain with protocol in your site management?


(pawan kumar) #3

I didn’t do such configuration, would you please help me out in this.

Please give bit more details so i could check it

Thanks in advance


(pawan kumar) #4

does anyone know about this,since my application is working on https but why static resource is taking HTTP and I checked “view page source


(Sebastian Helzle) #5

Usually you wouldn’t need any specific configuration.

You have an entry “Sites management” when you toggle the menu in the top left of the backend.
There you can setup your domain. If that doesn’t help, then your setup must have some specific change so Neos cannot detect the protocol correctly and render the links.


(pawan kumar) #6

The issue has been resolved as I was using the Nginx web server with php-fpm so I had to set below parameter fro the same

fastcgi_param HTTPS on;
fastcgi_param SERVER_PORT 443;

Issue got resolved since it was making all the request on HTTP instead of HTTPS.

Really thanks for being with this me.

Thanks,
Pawan Kumar


(Soren Malling) #7

Please mark this topic as [SOLVED] by editing the title of the topic