Database migration issues when trying to update from Neos 1.2.9 to 2.0.0-beta6 with example site package


for testing purposes I’m trying to update Neos from 1.2.9 to 2.0beta6, following the upgrade instructions. It’s a standard installation, including just the Demo Site and no customizations.

All steps involving Composer passed, but I cannot apply the database migrations. When I run

./flow node:migrate --version 20141103100401 --confirmation TRUE

I get the error

Node type "1" does not exist
  Type: TYPO3\TYPO3CR\Exception
  Code: 1316451800
  File: Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_TYPO3CR_Dom
  Line: 188

What am I missing? Any ideas?

One thing I noticed, differing from the instruction, is that I had to apply code migrations using the --force flag (not using the development version).

./flow flow:core:migrate --force

1 Like

I get the same error, with a new blank site package created from setup.

Now it works!
I used “flow kickstart:site” and then imported the site with setup!

Hi, got the same error.

Some NodeTypes were replaced with:

- ‘NodeType.example’ to ‘NodeType.example’: ‘1’ should be ‘NodeType.example’: true


- ‘NodeType.example’ to ‘1’: true should be ‘NodeType.example’: true

Open the error log and try to look for the NodeType that is shown in the error

I can confirm the issue, caused in my case by a core migration (TYPO3.TYPO3CR-130523180140)

The migration is older than the new syntax of the super types :frowning:

In my case the migration changed the NodeType.yaml in Packages\Plugins\Flowpack.Neos.FrontendLogin\Configuration from:

    'TYPO3.Neos:Plugin': 'TRUE'


    'TYPO3.Neos:Plugin': '1'

But that was wrong already, because ‘TRUE’ != TRUE (string vs. boolean). You should change that to just TRUE.

You are right - thanks!