Execution of subprocess failed with exit code 255

Hi, I would like to install NEOS on my web server. Use PHP 7.3 and it is a Linux server that I have full access to.

After installing with composer I get this error message:

Execution of subprocess failed with exit code 255 without any further output.

(Please check your PHP error log for possible Fatal errors) Try to run the command manually, to hopefully get some hint on the actual error. It has been stored in: 202001301955094ce8d6-command.txt

Exception Code 1355480641
Exception Type Neos\Flow\Core\Booting\Exception\SubProcessException
Log Reference 202001301955091a5080
Thrown in File Packages/Framework/Neos.Flow/Classes/Core/Booting/Scripts.php
Line 694

Does somebody has any idea?

Did you check the mentioned error log file? Located in Data/Logs

No. Can you please check that output? I do not understand this:

Exception #1355480641 in line 379 of /home/accountxy/public_html/neos/Packages/Framework/Neos.Flow/Classes/Core/Booting/Scripts.php: Execution of subprocess failed with exit code 255 without any further output. (Please check your PHP error log for possible Fatal errors) Try to run the command manually, to hopefully get some hint on the actual error. It has been stored in: 202001301955094ce8d6-command.txt

12 Neos\Flow\Core\Booting\Scripts::executeCommand(“neos.flow:core:compile”, array|16|)
11 Neos\Flow\Core\Booting\Scripts::initializeProxyClasses(Neos\Flow\Core\Bootstrap)
10 call_user_func(array|2|, Neos\Flow\Core\Bootstrap)
9 Neos\Flow\Core\Booting\Step::__invoke(Neos\Flow\Core\Bootstrap)
8 Neos\Flow\Core\Booting\Sequence::invokeStep(Neos\Flow\Core\Booting\Step, Neos\Flow\Core\Bootstrap)
7 Neos\Flow\Core\Booting\Sequence::invokeStep(Neos\Flow\Core\Booting\Step, Neos\Flow\Core\Bootstrap)
6 Neos\Flow\Core\Booting\Sequence::invokeStep(Neos\Flow\Core\Booting\Step, Neos\Flow\Core\Bootstrap)
5 Neos\Flow\Core\Booting\Sequence::invokeStep(Neos\Flow\Core\Booting\Step, Neos\Flow\Core\Bootstrap)
4 Neos\Flow\Core\Booting\Sequence::invoke(Neos\Flow\Core\Bootstrap)
3 Neos\Flow\Http\RequestHandler::boot()
2 Neos\Flow\Http\RequestHandler::handleRequest()
1 Neos\Flow\Core\Bootstrap::run()


FLOW_ROOTPATH=’/home/accountxy/public_html/neos/’ FLOW_PATH_TEMPORARY_BASE=’/home/accountxy/public_html/neos/Data//Temporary’ FLOW_CONTEXT=‘Development’ XDEBUG_CONFIG=‘idekey=FLOW_SUBREQUEST remote_port=9001’ “/opt/cpanel/ea-php72/root/usr/bin/php” -c ‘/opt/cpanel/ea-php72/root/etc/php.ini’ ‘/home/accountxy/public_html/neos/Packages/Framework/Neos.Flow/Classes/Core/…/…/Scripts/flow.php’ ‘neos.flow:core:compile’ 2>&1


TYPO3 9.— work on this Server perfect.

Had the same kind of error message.

Was able to trace it down to my ViewHelpers not using the initializeArguments()-Mehod to define the available arguments for the render()-Method.

But literally it could be anything! - Enable display_errors in your php configuration to get more hints or check your php error.log as already mentioned.

In my case (in a ViewHelper), before:

public function render($strIdentifier, $strLanguage)
{
	return $this->getLabelForKey($strIdentifier, $strLanguage);
}

anf after:

public function initializeArguments(){
	$this->registerArgument('strIdentifier', 'string', 'strIdentifier');
	$this->registerArgument('strLanguage', 'string', 'strLanguage');
}

public function render()
{
	$strIdentifier = $this->arguments['strIdentifier'];
	$strLanguage = $this->arguments['strLanguage'];
	return $this->getLabelForKey($strIdentifier, $strLanguage);
}

I will not use NEOS. I can’t get it to run on two different servers and local. NEOS is great but the installation is just so complex - no way.

Since you made up your mind, this is probably not relevant for you any longer. But it might be helpful for others experiencing issues with PHP 7.3.
It could be related to that Fluid bug: https://github.com/TYPO3/Fluid/issues/449