Neos 2.1 content dimensions setup

I’m trying the brand new 2.1 version and found myself stuck setting up content dimensions, i tried them on 2.0 and they worked flawlessly therefore I think I’m messing something up but I can’t see what .
The steps I followed:

  • created an “empty” site package with kickstart command;
  • added Settings.yaml with content dimensions example from neos documentation (language/country dimensions)
  • applied the node migration 20140326143834 as from documentation

When I then reload my backend I get stuck with error:

1301610453: Could not resolve a route and its corresponding URI for the given parameters. This may be due to referring to a not existing package / controller / action while building a link or URI. Refer to log and check the backtrace for more details.

Checking System_Development.log I get this:
15-12-28 08:59:51 243 WARNING Flow Router resolve(): Could not resolve a route for building an URI for the given route values.
node => ␀
action => show
controller => frontend\node
package => typo3.neos
format => html

For my tests I use million12 docker package, if it could be involved.

Anyone has a clue on what am I missing here?

Going deeper with my tests I found out that the backend user workspace does not get a baseworkspace, setting it manually into the db restores the backend but another issue comes out: there is no content dimensions selector in the backend, even if they show up in the configuration module correctly.

Any clues?


Thanks to @aertmann and @dimaip on slack the issue seems to be solved.
It was a problem of browser cache; an hard reload (Ctrl+Shift+R on Chrome) made it work back like supposed.

Thanks to everyone,