No such file or directory after upgrade to Neos 2.3

Good Morning,

I’m running into an issue after upgrading to Neos 2.3 (2.3.8).
After I did all the upgrading stuff (composer update, flush cache, warmup cache, core migrate, doctrine migrate), I’m getting the following error:

21-Dec-2016 07:34:01 Europe/Berlin] PHP Warning:  Uncaught exception 'TYPO3\Flow\Error\Exception' with
 message 'Warning: require_once(/Applications/MAMP/htdocs/neos-local/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/../../../Resources/Private/PHP/php-peg/Parser.php): 
failed to open stream: No such file or directory in 
line 15' in /Applications/MAMP/htdocs/neos-local/Packages/Framework/TYPO3.Flow/Classes/TYPO3/Flow/Error/ErrorHandler.php:81

Does one of you know why this could happen?
I’ve already asked this question in Slack and Christian Müller mentioned that he thinks the Eel Abstract parser maybe shouldn’t have a proxy class. I’ve checked this on another Neos project with Neos 2.3 running and there is no proxy class indeed but I don’t know how to fix it in this case.


Just checked and indeed it doesn’t have one for me.

Yeah, it only is generated in that very installation for me as well but the question is how can I find out why it’s being generated :slight_smile:
What I’ve tried so far:

  • Different versions (2.3.5, 2.3.6 etc.)
  • Removing everything under Packages, except my Site package and doing a composer update (just in case something strange happens there)
  • Doing an Upgrade from 2.1 to 2.2, then 2.3 or directly 2.1 to 2.3 with the same result - it doesn’t work. 2.2 works fine.

What is the point where Flow decides if a Proxy class is generated?

High probability it is some AOP advice that applies to this or a child class.

I guess we should/could mark this as Proxy(false)

Would you open an issue for that?

Sure, here it is: