[SOLVED] Boolean properties problem with site import/export


(Achim Gottinger) #1

Hi,

An boolean property with the defaultValue TRUE, set to False and export via flow site:export endsup as in the xml export file.
If I import this and run flow repair:node afterwared it’s value is set to the defaultValue TRUE.
As an workaround i changed the defaultValue to False, that way it works.
Not so sure which package that bugs belongs to so i report it here.

Update: Seems the defaultValue is also applied for empty text properties after an import.

Achim~


(nicola Cerchiari) #2

I think I can add some info about a very similar issue we got.
On Neos 3.2.0 we are getting the following exception when we try to site:export a NodeType boolean property set (troe or false seems not to matter).

1 exceptions occurred during export. Please see the log for the full exceptions (including stack traces). The exception messages follow below: 0: Neos\Flow\Property\Exception Exception while property mapping for target type "string", at property path "": No converter found which can be used to convert from "boolean" to "string".

I saw this happens with several packages even with some not developed directly by us, therefore I think the problem is not in the package itlsef.

Any clues?

Thanks,
Nicola


(Daniel Keller) #3

My site-backup stopped working for this reason.

I backup the site with:
./flow site:export --site-node xxxx --filename /home/xxxxx/neos_export.xml

I get:

0: Neos\Flow\Property\Exception
Exception while property mapping for target type "string", at property
path "": No converter found which can be used to convert from "boolean"
to "string".

Any help and resolution for this would be greatly appreaciated!!!


(Marvin Enghardt) #4

Same problem here.


(Bastian Waidelich) #5

Hi,

this seems to be a regression in the last releases (see https://github.com/neos/neos-development-collection/issues/1732).
We‘ll be looking into this tomorrow and update the ticket accordingly.


(Bastian Waidelich) #6

FYI: A hotfix has been pushed, but still needs reviews: https://github.com/neos/flow-development-collection/pull/1109


(Bastian Waidelich) #7

FYI2: The bug should be fixed with latest bugfix releases


(Peter Rauber) #8

Bug is still present on my Neos 3.2.1 project.
I thouhgt it needs a bugfix in Flow but mabye I got that wrong.


(Bastian Waidelich) #9

Thanks for the feedback. I confused the releases. The Flow patchlevel release is on its way!


(Gerhard Boden) #10

Now it’s official :slight_smile:


(Peter Rauber) #11

And I can confirm, the export works now. :slight_smile: Thank you guys.