[SOLVED] Database setup problems in Neos 2.1.5

Hi all,
I’m trying to install a new website based on the latest Neos 2.1.5 but I got stuck at database setup.
No matter I correctly filled in the form as selected the made-on-purpose new database from the selectbox, I receive this error:
Database “[db_name]” could not be created. Please check the permissions for user “[db_username]”. DBAL Exception: “An exception occured in driver: SQLSTATE[28000] [1045] Access denied for user ‘[webserver_username]’@’[db_host]’ (using password: NO)”.
From what I can see there are apparently 2 problems:

  1. The setup tries to create a new database ignoring I chose an existing one
  2. It tries to connect to db server with the webserver user and of course fails

I don’t know if the first problem is a fake generated by the fact it cannot connect to the db server, but I can’t move forward.

Any clues? (Even on how to work around it)


Sorry, in our git repo was uploaded an default Setting.yaml that was generating the error.

Problem solved.

Thanks anyways,

1 Like