[Solved] No 404/not-found Page when using Dimensions (or MOC/notfound package broken?)

Hi,

I’m just with testing the Dimension-Feature a bit more - but now, the 404-page (MOC-notfound Package installed) won’t show up when entering a non-existing path. It just displays the start-page (/) :frowning:

Dimensions:

  • Language, just -de- with uriPathSegment ‘’
  • Audience, (audience1 with uriPathSegment ‘’, audience2 with uriPathSegment ‘m’ and a Fallback to audience 1)

Appreciate some help and hint for solving this :-). Thanks alot.

I have similar situation with moc/notfound.
My config looks like this:

ContentRepository:
__contentDimensions:
____language:
______label: Language
______icon: ‘icon-language’
______default: de
______defaultPreset: de
______presets:
________‘de’:
__________values: [‘de’]
__________uriSegment: ‘’
__________label: DE

Edit: Looks like updating to latest minor release (4.0.21) broke moc/notfound.
The build 4.0.18 works fine.

I’m not sure why moc/notfound shouldn’t work, but remember that you can replace the plugin with Neos core functionality since 4.3: https://www.neos.io/blog/neos-4-3-and-flow-5-3-released.html

1 Like

Will test that soon.
But it even does not explain the behaviour.

[edit]
Just throw away the moc/notfound :frowning:
With the code-snippet provided from the link it doesn’t show the right page-layout.
Fiddeling around to switch simplier from moc - I came over with this error.fusion (and it worked, whyever):

# Error matcher to render the 'notfound' child-document of the homepage
# for exceptions with 4xx status code
error {
    @context.notfoundDocument = ${q(site).children('[instanceof Neos.Neos:Document][uriPathSegment="404"]').get(0)}
    4xx {
        @position = 'start'
        condition = ${statusCode >= 400 && statusCode < 500 && notfoundDocument}
        renderer = Neos.Fusion:Renderer {
            @context.node = ${notfoundDocument}
            @context.documentNode = ${notfoundDocument}
            renderPath = '/root'
        }
    }
}

but does that even indicate a 404 to e.g. search engines?
[Edit] It does - looked up the header. Thanx :slight_smile:

1 Like