[Solved]Swiftmailer versendet im Produktiv Stand keine Mails

Guten Morgen,
ich habe das Problem, dass mein Swiftmailer im Produktiv Stand keine E-Mails versendet, jedoch im Development schon.
Wenn ich mir die Settings anzeigen lass, werden diese korrekt angezeigt.
Muss ich da noch irgendwelche besonderen Einstellungen vornehmen oder hab ich irgendwas übersehen`?

Vielen Dank schon einmal

Moin Manuel,

was nutzt du denn für Settings im Produktiv-Modus?
Sendest du die Mails per SMTP über einen anderen Mailserver oder von lokal auf dem Webserver?
Vielleicht kannst du uns ja mal deine Einstellungen Zeigen (ohne Userdaten natürlich) oder ggf. einen Fehler-Log aus Data/Logs/Exceptions (sofern vorhanden)?

Viele Grüße
Niklas

Guten Morgen Niklas,

ich nutze einen SMTP Server von HostEurope, die Verbindung mach ich in den Swiftmailer Settings:

Swiftmailer:
 transport:
  type: 'Swift_SmtpTransport'
  options:
    host: '******.server-he.de'
    port: '25'
    username: '*****'
    password: '*****'

Ansonsten nutze ich für den Produktiv-Modus keine extra Settings.
Es wird keine Log erstellt, es kommt auch allgemein kein Fehler, die Mail wird einfach nicht zugestellt.
Der SMTP wurde mir von meiner Firma zur Verfügung gestellt, jedoch hab ich keinen direkten Zugriff darauf (leider).

Viele Grüße
Manu

Die config an sich sieht auf den ersten Blick gut aus. 2 Sachen sind mir aber aufgefallen:

  • Es steht kein Neos: vor SwiftMailer:
  • Swiftmailer: ist nicht ganz korrekt (das M von “Mailer” müsste groß)

Vielleicht sind das auch einfach nur Sachen vom kopieren, du solltest es aber einmal auf dem Server checken. Am besten schaust du, ob dir Flow mit dem Befehl ./flow configuration:show --path Neos.SwiftMailer.transport die richtigen Werte ausgibt.

Wenn das alles stimmt, könntest du vielleicht die Zugangsdaten mal in einem Mail-Programm ausprobieren. Also ob die Kombination host/port/user/passwort überhaupt funktioniert und von dort mal eine Test-Mail versenden.
Manche Provider erlauben auch gar keine unverschlüsselte Übertragung mehr. Vielleicht liegt es auch daran. Dann müsstest du noch eine Verschlüsselung in der Konfiuration angeben. Aber dafür kenne ich HE nicht gut genug.

Bin gespannt was du so rausfindest :wink:

Also ich hab jetzt mehrere Dinge versucht und nichts hat funktioniert.

Die config an sich sieht auf den ersten Blick gut aus. 2 Sachen sind mir aber aufgefallen:

  • Es steht kein Neos : vor SwiftMailer:
  • Swiftmailer : ist nicht ganz korrekt (das M von “Mailer” müsste groß)

Das war richtig drin, war aber zu blöd zum kopieren.

Am besten schaust du, ob dir Flow mit dem Befehl ./flow configuration:show --path Neos.SwiftMailer.transport die richtigen Werte ausgibt.

Der Befehl gab die richtigen Werte aus.

Jetzt kommt das beste, ich hab auf dem selben Server noch eine separate Neos Instanz laufen und bei der funktioniert das alles, sowohl im Produktiv, als auf im Entwicklungs-Modus.
Hab auch alles miteinander verglichen, aber es gibt keine Unterschiede und ich kann mir das alles nicht erklären.
Ich kann ja schlecht die Seite im Entwicklungs-Modus lassen, nur damit die Mails versendet werden.

Sieht die Konfiguration identisch aus, wenn du in Neos Backend auf Konfiguration gehst und dort nach den Swiftmailer Einstellungen schaust?

Guten Morgen Sebastian,

tatsächlich nicht, bei der Produktiv Seite werden die Einstellungen von mir nicht angezeigt sonder leere Standardparameter. Wenn ich aber den FLOW_CONTEXT änder sind die richtigen Parameter drin. Woran kann das liegen?

In welcher Settings-Datei (Pfad) hast du denn die Einstellungen gesetzt?

Damit diese im Produktivmodus greifen, solltest du diese unter Configuration/Production/Settings.yaml liegen haben.

Hatte es im Settings Pfad vom Swiftmailer drinnen, so hat es auch beim anderen funktioniert, bin davon ausgegangen dass die Settings global gelten.

Habe es jetzt in die Production Settings verschoben und es funktioniert jetzt.

Vielen Dank euch beiden für eure Hilfe :slight_smile:

In Packages, die nicht teil von deinem Projekt sind und mit Composer installiert wurden, darfst du keine Settings anpassen, oder hinzufügen. Diese würde nicht übertragen, wenn du dein Projekt woanders installierst.

Daher muss die Konfiguration immer entweder z.B. in dein Sitepackage oder in den Configuration Ordner im Projektverzeichnis. Und je nachdem wo Einstellungen gelten sollen, dann under dem Production/Development Unterordner oder einfach in die oberste Settings.yaml direkt im Configuration Ordner.