Error "Invalid argument supplied for foreach"

Hey everyone,
first of all, I would like to point out that I am relatively new to Neos. A few days ago, I created a site package for one of my projects - again - without any problems. Unfortunately, something got twisted and I was facing the following error, which - as far as I know - occured after executing a cache:flush

An exception was thrown while Neos tried to render your page
Warning: Invalid argument supplied for foreach() in /var/www/vhosts/ line 140

root<Neos.Fusion:Case>/ documentType<Neos.Fusion:Matcher>/ element<MY.Myproject:LandingPage>/ head<Neos.Fusion:Array>/ stylesheets<Neos.Fusion:Array>/ site<Neos.Fusion:Template>/`

My Root.fusion looks like this:

prototype(MY.Myproject:LandingPage) < prototype(Neos.Neos:Page) {
    head {
        meta = Neos.Fusion:Template {
            templatePath = 'resource://MY.Myproject/Private/Templates/Page/Landing.html'
            sectionName = 'meta'

        //Stylesheets = Neos.Fusion:Template {
            templatePath = 'resource://MY.Myproject/Private/Templates/Page/Landing.html'
            sectionName = 'stylesheets'

        //Head JScripts = Neos.Fusion:Template {
            templatePath = 'resource://MY.Myproject/Private/Templates/Page/Landing.html'
            sectionName = 'headScripts'

All sections are mentioned in the referenced Landing.html. I also tried the following commands to fix it:

./flow flow:cache:flush (--force)
./flow node:repair
./flow resource:clean

Hope anyone can help me with this :slight_smile:


Could be related with: Frisches Neos 4.3 mit Demo Package - Exception im Hauptmenü

I fixed the problem by downgrading the typo3fluid package from 2.6.1 to 2.6.0 and the php version from 7.3 to 7.2