Neos project mono repositories

(Martin Ficzel) #21

@christianm yes offcourse, planning some splash work the next weeks anyways

Error because of language configuration
(Thomas Buhk) #22

I know the voting is done and i am 10d to late for this, but i am very unhappy with this since all other directories and names in flow/neos follow the camelcase style. The goal to install all packages by composer is great, but ./src looks like a pothole inside project repositories.

(Soren Malling) #23

Consider src a storage for your packages, when running a mono repository. Alternatively, you will have multiple Git repositories, and require them via composer.json and enter the repositroies in the configuration.

The src is just for a documentation purpose - you can call it whatever you want. This poll is not reflected in any core code, that will make your project none-functional, if you don’t use it. So the naming is up to you.

(Thomas Buhk) #24

I know Soren that this will not change any core package. It will be a best practice suggestion from the core team. But a suggestion from the core team will weighs sometimes like a rule to other developers. And not follow the core flow/neos directory naming will confuse some others…

My comment is only to have this in mind when making best practice advices.

(Robert Lemke) #25

For the record, I also dislike “src” for the reason of not fitting into the overall Flow directory structure. I suggested DistributionPackages back then and unfortunately missed this discussion here.

(Karsten Dambekalns) #26

I voted for DistributionPackages back then. And then forgot about this poll, TBH.

But seeing a majority for src makes me cringe. Probably we missed to explain why that would be a bad name…

  • src is “random”. It could be just about anything. Everything in a Git repository is source, somehow, no?
  • src violates our naming conventions. In Flow we usually have no files/folders starting with a lowercase character.
  • src is an abbreviation. We usually try to avoid those and favour telling names.

The suggested DistributionPackages on the other hand fulfills all our wishes and clearly explains what it contains - packages that are shipped with the distribution.

I’d urge everyone to consider this, and I’d even dare to ignore the vote in this case…

(Christian Müller) #27

As the original poll doesn’t show who voted (and so we cannot look at team member votes, and was just asked about this), I would like to redo this vote:

  • LocalPackages
  • DistributionPackages
  • Source
  • src

0 voters

(Dmitri Pisarev) #28

Not opinionated, both Local and Distribution Packages sound OK.

(Soren Malling) #29

I respect all opinions, but let’s state again: It’s just a folder containing whatever your needs might be for your mono repository. 99% comes from composer.json dependencies anyway. And whatever will be voted will be a part of the documentation, but no one is locked to that name. So name it, whatever makes sense in terms of documentation and understanding of what it’s there for :slight_smile:

And yes, I was the one bringing up src because that’s a name I’ve seen in oh so many other frameworks and libraries, when structuring code and used it my self. I have no big love or feelings for that name :slight_smile:

(Gerhard Boden) #30

same here, both respect the recommended naming conventions and are equal to me when it comes to semantics

(Martin Ficzel) #31

I will accept whatever the majority does but agree that DistributionPackages and LocalPackages look much nicer in a flow-distribution.

(Christian Müller) #32