Broken css includes in backend after update to 2.1.4

Hi everyone,

I just updated my Neos site to 2.1.4. Now I don’t get the CSS in backend. The include looks like this:

<link rel="stylesheet" type="text/css"

while it should look more like this:

<link rel="stylesheet" type="text/css"

I’ve already tried a ./flow resource:publish but that didn’t change anything. Also, frontend and login screen work just fine.
Any ideas?

Thank you in advance :smile:

same problem here.
Tried to:

  • clean and publish resources
  • clear caches
  • core migration
  • nodes migrations and repair
  • doctrine migration

Everything went good but the problem persists.

One note: I got the problem on all backend modules but content editing (i.e. Administration, Management, …).


Yes exactly, content module works just fine.
I wonder if this might be related to “BUGFIX: Additional styles for modules loaded after Neos”, although in the corresponding comment there is no noticeable difference in how the stylesheet is included. Could it be possible that the f:uri viewhelper behaves differently?

Hi all,

Same problem with me.
With a problem on the administration configuration page access, see the discussion here

if it’s of any help the problem, from a quick test, seems to generate in file: TYPO3.Neos\Resources\Private\Templates\Backend\Module\Index.html (lines 9).
In content editing the same snippet is called from file TYPO3.Neos\Resources\Private\Templates\TypoScriptObjects\NeosBackendHeaderData.html (line 11) instead, and the ways the link is generated are different:


<link rel="stylesheet" type="text/css"
    				  href="{f:uri.resource(path: 'Styles/Includes-built.css?bust={neos:backend.cssBuiltVersion()}', package: 'TYPO3.Neos')}"/>


< link rel="stylesheet" type="text/css" href="{f:uri.resource(path: 'Styles/Includes-built.css', package: 'TYPO3.Neos')}?bust={neos:backend.cssBuiltVersion()}" />

in the first the query string is included into the <f:uri.resource> viewhelper path property

My 2 cents and hope it helps,

Fixed with

Will release new releases

Thank a lot aertmann. It’s good for me.

For information, this fix has not resolved the problem on the administration configuration page access, see the discussion here