Can't create a site package with Neos 4.3


(Matthias Lang) #1

Hi there,

Since yesterday I’m trying to start with a new Neos site but I can’t create a blank site package neither with the setup tool nor with the command line. I get this error since Janurary’19, Neos 4.2 I think.
Last time I solved it with removing the distributionPackages in the repositories section in composer.json but I think that can’t be a permanent solution.

I realised that others have the same problem but the topic was never solved: Problem with Neos 4.2 when creating new package?

The error:
Notice: Undefined index: vendor/examplecom in /var/www/example.com/Packages/Framework/Neos.Flow/Classes/Package/PackageManager.php line 388

I’m glad for help!
Matthias


(Martin Ficzel) #2

The only issue I am aware of is a configured private packagist in the repositories section. A fix for that is in the 5.2 brach but still has to be upmerged and released.

Other than the private-packagist issue I am not aware of problems. How does your setup look and what commands did you execute?


(Martin Ficzel) #3

Especially interesting would be OS, PHP Version and the Composer Version.


(Matthias Lang) #4

Hey @martoro!

Now I just made a clean, new Neos project. I jumped right into the setup without installing custom repositories or making any changes. However, in the setup when creating a new site package I get an error again. It’s just a 500. So what I found in the logs:

CRITICAL                       Exception in line 673 of /var/www/example.com/Packages/Framework/Neos.Flow/Classes/Package/PackageManager.php: Argument 5 passed to Neos\Flow\Package\PackageFactory::create() must be of the type array, null given, called in /var/www/example.com/Packages/Framework/Neos.Flow/Classes/Package/PackageManager.php on line 673 - See also: 201904250734156eea5b.txt

My System: Debian 9.8, PHP 7.2, Composer 1.8.5

Since Neos 4.3 another problem on my system is that I have to manually do a ./flow cache:warmup, otherwise the setup page has no CSS and JS.

I hope you have a better overview no and thanks for the help!
Matthias


(Matthias Lang) #5

Oh and this it says in the further logs:
29 Neos\Flow\Package\PackageFactory::create("/var/www/example.com/Packages/", NULL, NULL, "vendor/examplecom", NULL, NULL)

Looks like the params get not assigned.


(Martin Ficzel) #6

Can you try those commands on the cli and tell me what the second and third line returned

composer create-project neos/neos-base-distribution 4-3-test
cd 4-3-test
./flow package:create --package-type neos-site --package-key Vendor.ExampleCom
./flow kickstart:site --package-key Vendor.Example2 --site-name example2

They use two different commands to create a site package, i ran those exact commands a minute ago without problems.


(Matthias Lang) #7

Hey @martoro!

The package was created successful with both commands (the package and kickstart). The packages were created in DistributionPackages and symlinked in Packages/Sites. Looks perfect!
However I just tested it with the setup tool and I still get the same error…
I can work with the command now on my project, but it would be interesting what causes the setup tool to fail.


(Martin Ficzel) #8

Thanks for the feedback, good to know the error is in setup and not in Flow itself?

We will look into it but without rushing as the cli does work as workaround.