I’ve been using neos for a while and I’ve developed a few custom packages over this time. It was all based on neos 5.1 and now I wanted to try to upgrade to the newest version available. I followed the guide on the website, and went from 5.1 -> 5.2 and the 5.2 -> 5.3 with no problems, but now, trying to upgrade to 7.0 I’m getting some problems. I’m still following the guide and when I have to run composer update I get this error in the console.
It says I have the wrong version of PHP’s Json extension, but I do have it on my server and in the composer.json and composer.lock every occurrence is set like this:
It also says to not install neos 7.0 but I think that it might just be errors. I’ll try to figure this out, but I could really use some suggestions!
Thanks in advance!
I’m not sure why it complains about ext-json, but it definitely looks like you’ll need v5.0.0 of
neos/redirecthandler-databasestorage alongside your Neos update: https://packagist.org/packages/neos/redirecthandler-databasestorage
I suggest, you try adjusting the version constraint for
neos/redirecthandler-databasestorage in your root composer.json and then run the update once again. Maybe this is going to fix your problem entirely, since the complaint about ext-json stems from Neos versions below 7.0.
Hope this helps!
flow [....] requires ext-json ^1.2 that is an old buggy constraint that was alleviated with Flow 5.3.9+, so indeed that should fix itself once the other constraint is resolved.