Could not find root node

Hi guys,

I am running Neos 2.1.3 on an all-inkl webspace with ssh access and I tried to update to 2.1.5 via composer, but I failed miserably. After executing:

composer update --no-dev "typo3/*"
# Remember to flush the caches afterwards
./flow flow:cache:flush --force
./flow doctrine:migrate
./flow resource:publish

All content was gone, only the layout from my own site package with welcome message was visible. Running ./flow node:repair showed at the top:

Could not find "/sites" root node

I found an issue with a similar error message and therefore I looked for the “/sites” node in typo3_typo3cr_domain_model_nodedata, but without success. I tried to insert it, but I didn’t know which value to choose for persistence_object_identifier.

I ended up with a rollback to 2.1.3. Any ideas, what went wrong?

Sounds similar to these threads Changing type of Homepage-node causes Footer to throw an exception or How do I fix "Unable to find a valid document up in the document tree" without access to the backend?.

I saw both threads and linked the first one in my post, but I need a little more help as:

They are a bit tricky to solve, but can be done in the database in the nodedata and nodedimension tables.

I was able to get around this in the following way: First I had to add dimensions.

        label: 'Language'
        icon: 'icon-language'
        default: 'de'
        defaultPreset: 'de'
            label: 'German'
            values: ['de']
            uriSegment: 'de'
            label: 'English'
            values: ['en_US']
            uriSegment: 'en'

Set all nodes to the default language with the following command:

./flow node:migrate 20140326143834

Afterwards I had to remove dimensions and execute the migration step once again.

Vola, all nodes are back again, except the root node. This was a shortcut, now it is a normal page. Weird behavior, but as long as it is working, I will not complain :wink:.

Thanks for your help.

Glad you found a solution.

Good morning,

I’ve the same problem as @sualko.

Yes, nodes are back in my case, too. But I think… [quote=“sualko, post:4, topic:971”]
I had to remove dimensions
…should’nt be the end of solution.

@aertmann: Do you have any idea how to fix this? If I add dimensions again afterwards, I run into the same problem(Could not find "/sites" root node) again, of course :confused: