Could not publish: directory could not be symlinked


How would I continue to this?

Could not publish: because the source directory could not be symlinked at target location.

Screen Shot 2021-07-20 at 4.48.55 PM

I already tried modifying the Settings.yaml based on this.

But it has a message error:
Nested Exception
Warning: symlink(): File exists in /home/www/Packages/Libraries/neos/utility-files/Classes/Files.php line 522

I also could not use ./flow help cause it will result the same error.

Can someone point me to the right directions on how to work on this?

Thank you so much!

Did you copy the Web/_Resources folder before?
Just try deleting it and run ./flow resource:publish

Yeah I did, and I got this error:

PHP Warning: Uncaught Neos\Flow\Error\Exception: Warning: require(/home/www/Data/Temporary/Development/Doctrine/Proxies/__CG__NeosFlowResourceManagementPersistentResource.php): failed to open stream: No such file or directory in /home/www/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 209 in /home/www/Packages/Framework/Neos.Flow/Classes/Error/ErrorHandler.php:81

Stack Trace:
PHP Fatal error: Doctrine\Common\Proxy\AbstractProxyFactory::getProxyDefinition(): Failed opening required ‘/home/www/Data/Temporary/Development/Doctrine/Proxies/__CG__NeosFlowResourceManagementPersistentResource.php’ (include_path=’.:/usr/share/php’) in /home/www/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

Seems your cache is completely broken. Delete the Data/Temporary folder

1 Like

Amazing! It works!
Thank you soo soo much Sebastian!

What I did:

  1. Delete Web/_Resources folder
  2. Delete the Data/Temporary folder
  3. Run ./flow flow:cache:flush
  4. Run ./flow resource:publish


1 Like