Create package not working

Hello all,

I am trying to create a package under Neos Flow 6.3. Unfortunately this does not work properly. Google does not help me enough with the error messages. Do you have an hint for me?

The exception output:

Exception #1572187932 in line 99 of /var/www/html/public/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/Neos_Flow_Command_PackageCommandController.php: The installation was not successful. Composer returned the error code: 2

11 Neos\Flow\Package\PackageManager::createPackage()
10 Neos\Flow\Command\PackageCommandController_Original::createCommand()
9 Neos\Flow\Cli\CommandController_Original::callCommandMethod()
8 Neos\Flow\Cli\CommandController_Original::processRequest()
7 Neos\Flow\Cli\Dispatcher_Original::dispatch()
6 Neos\Flow\Cli\CommandRequestHandler::Neos\Flow\Cli\{closure}()
5 Closure::__invoke()
4 Neos\Flow\Security\Context_Original::withoutAuthorizationChecks()
3 Neos\Flow\Cli\CommandRequestHandler::handleRequest()
2 Neos\Flow\Core\Bootstrap::run()
1 require("/var/www/html/public/Packages/Framework/Neos.Flow/Scripts/flow.php")

I changed the composer.json:

"require": {
    "neos/flow": "~6.3.0",
    "neos/welcome": "~6.3.0",
    "composer-runtime-api": "^2.0.0"

and did composer update and composer install but no change :frowning:

Thanks a lot for your support!


Sorry, I missed a very important point: I’m using Composer 2.0.8

composer clear-cache
… may help ?

see …

… point 5 …

Thank you very much for your prompt reply.
I cleared the cache - without success :frowning: I got the same error. I tried to shift the requirement to “require-dev”, but the same problem.

Suppose you did remove the added line

“composer-runtime-api”: “^2.0.0”

from your composer.json

… before ‘composer clear-cache’

I tried both: clear cache with and without the related composer.json entry. No success.

When I insert the entry, the error looks slightly different:

So it seems, that composer-runtime-api is installed, but in 1.0.0.
Composer itself is at 2.0.8:


Just wanted to be sure, the basic caches were cleared properly

  • composer …
  • flow … remove Data/Temporary/

So, I hope somebody who has insights in the underlying ‘mecanics’ will be able to help you further …

Thanks Christoph, yes, you’re right - all caches are flushed. But no success…

I downgrated Composer to 1.10.19 and cleared all caches. Now it is working. So it seems, we have a problem with Composer 2.0.x?

Yes, we added composer 2 support for Flow 7, but in the meantime noticed we should have also added that for all supported versions. The according change is already merged and just needs a release:
Maybe we can make this happen the next days, as we also have an urgent bugfix for 7.0 in the pipe.

Thanks Alexander! This sounds great - from my side, no need to hurry :smiley: