Custom 404 Page [SOLVED]


(Muhammad Tashfeen) #1

Hi,

I am on neos 3.1. I want to build an editable 404 page there are two packages I came across
1- https://www.neos.io/download-and-extend/packages/sitegeist/sitegeist-movealong.html
2- https://www.neos.io/download-and-extend/packages/moc/moc-notfound.html

The first one doesn’t support neos 3.1. The second one when I composer install it the site gives the following error ‘TYPO3\Fluid\Core\ViewHelper\AbstractViewHelper’. What am I doing wrong here. I have created the page via the dashboard and the url segment is notfound, What should I add to my Settings.html to make it work ?

`Fatal error: Class 'TYPO3\Fluid\Core\ViewHelper\AbstractViewHelper' not found in /home/vagrant/webseiten/neos0/Packages/Application/MOC.NotFound/Classes/MOC/NotFound/ViewHelpers/RequestViewHelper.php on line 19`

Thanks in advance.


(Muhammad Tashfeen) #2

The error went away with the version upgrade of moc/notfound package but the setting of my error page with url segment “notfound” is what I am still struggling with. Can anyone guide me about what I need to add to my Sites Settings.yaml to point to the “/notfound” page incase of any error.

Thanks


(Rene Rehme) #3

Hi,

I think you have installed the wrong moc/notfound package version because of the not existing “TYPO3” namespace.
If your running neos 3.1 you should install 3.0.1: https://packagist.org/packages/moc/notfound#3.0.1

For configuration: You can look into Settings.yaml -> https://github.com/mocdk/MOC.NotFound/blob/3.0.1/Configuration/Settings.yaml

Based on this structure you can override path: '404.html' in your site-package Settings.yaml.


(Muhammad Tashfeen) #4

Thanks for the answers. Turns out I was doing the configuration wrong. The solution was to install it and then just create a page with URL segment “404”. I initially was doing it via Settings.yaml.


(Rene Rehme) #5

@mtashfeen Nice! Please prefix the title of your thread with “[SOLVED]” for a better overview :slight_smile: