Discussion: Streamline usage of "Adaptor" vs. "Adapter" in code for Flow 4.0/Neos 3.0?

Moving the discussion here from slack to decide on this openly:

Alexander Berl [10:18 AM]
One question on something that is bugging me for a bit now: Who named the package “Fluid.Adaptor”? And do we maybe want to correctly spell it before the release?

Dmitri Pisarev [10:22 AM]
would have never noticed myself

[10:22]
just keep it a secret

Robert Lemke [10:22 AM]
we were aware of it. It’s a mess - we have both notations all over Flow and Neos.

Alexander Berl [10:23 AM]
hm, ok, apparently, both writings are “correct”, it’s just that “Adapter” is the much more widely used spelling

Dmitri Pisarev [10:23 AM]
http://grammarist.com/spelling/adapter-adaptor/

Alexander Berl [10:23 AM]
@robert might still be a chance to correct and streamline the spelling now, no?

[10:25]
I mean while we already have all the renaming mess anyway

Robert Lemke [10:26 AM]
you mean, everywhere in Flow / Neos?

[10:27]
sigh. Then I guess we won’t release this week anymore.

Alexander Berl [10:27 AM]
yeah, from a quick search it seems like 95% of “Adaptor” stems from the FluidAdaptor package

Robert Lemke [10:28 AM]
Let’s move over to some public channel, ideally Discourse and check if we need to postpone the release in order to get that right. I agree, it’s a chance, but …

Some quick facts:

  • Both writings are valid according to dictionary (https://en.oxforddictionaries.com/definition/adapter), but “Adapter” is the far more widely used spelling (360 M google hits, vs. 65 M hits for “Adaptor”)

  • Currently, as of the 4.0 branch of Flow the word “Adaptor” has 100+ occurences, nearly all coming from the FluidAdaptor package. The word “Adapter” has 53 occurences, coming from CacheAdapter and StreamWrapperAdapter

  • UPDATE: as of the 3.0 branch of Neos the word “Adaptor” also has 100+ occurences, again nearly all coming from FluidAdaptor package plus from NodeDataLabelGeneratorAdaptor. The word “Adapter” has 38 occurences, coming from redirecthandler-neosadapter and otherwise mainly from the frontend javascript frameworks (ember.js, vie.js, select2.js…)

  • UPDATE2: The nature of this change is purely cosmetic, it has no other reasons, so consider this when voting!

So the question is: Should we go the extra mile and deal with this inconsistency now, possibly delaying the Release schedule?

  • Yes, go consistent possibly delaying release schedule
  • No, keep as is and stick to release schedule
  • I don’t care really

0 voters

If we had to go with a single consistent spelling, which should we pick?

  • Go for “Adapter”
  • Go for “Adaptor”

0 voters

EDIT: Fixed occurences of “Adapter” in Flow codebase (previously 54) and added numbers for the Neos codebase

Your stats are screwed, TreeWalkerAdapter is from doctrine and if you do that on an entire Flow/Neos installation it might look different.

In general adapter is probably more used than adaptor but I think if we changed it we also must change the ES CR Adaptor package…

I also would like to point out that all this was discussed and decided in the project-fluid-coord channel that was open for everyone and also could have brought up in the code review for the fluid adaptor. So IMHO it’s a bit late for that. A decision was made and I don’t think it has any bigger impact on things.

Your stats are screwed, TreeWalkerAdapter is from doctrine and if you do that on an entire Flow/Neos installation it might look different.

That’s correct, TreeWalkerAdapter is from doctrine - but I could only find one occurence inside the Flow code anyway. Gonna correct the post. Regarding the Neos numbers, I’ll just quickly try to setup a neos project locally and get the numbers.

I also would like to point out that all this was discussed and decided in the project-fluid-coord channel that was open for everyone and also could have brought up in the code review for the fluid adaptor. So IMHO it’s a bit late for that.

That really must have passed by me, so maybe that’s a bit of fault on my side too, I must admit. But look at it this way: We currently have a definite inconsistency in the code base regarding that usage and we now have a big bang release with lots of renaming mess anyway. So this is probably our best chance in a whole while to fix this.

I don’t think it has any bigger impact on things.

Absolutely right, it’s merely a style inconsistency, no big impact at all.

FYI: The original discussion about the Fluid package: https://neos-project.slack.com/archives/project-fluid-coord/p1475651486000002

Personally I prefer “adapter” because I’m used to it. But I don’t think that we need to “streamline” this after the fact…

1 Like

Thanks for the link!

side note: I agree, and you’re right that the decision has been taken and everyone could have participated. However, for future decisions I suggest that we consider using our new decision scheme more often. In future cases like these (defining a name of a core package and unsure about the name) we should put up a Discourse post and ask the team to vote. Because I can also understand that not everyone in the team follows all initivatives, and sometimes decisions like these also get lost in the stream of a Slack conversation.

2 Likes

Of course, now that we have a process. But I would like to stress that in a major undertaking like the Fluid thing I don’t see myself setting up countless decision processes for people that are not even involved. Also it’s pretty hard in such a flow of work to decide what might be a worthy decision and what not. In hindsight I cannot even say that I would have put this up for the decision process if it had been in place back then. IMHO it’s a minor detail.

Closed the polls, I guess the votes were clearly in favor of sticking with the inconsistency instead of delaying the release further. Thanks everyone for voting!