Elasticsearch index entry point

Elasticsearch does not index the homepage. Every other page is listed but not the homepage. I tried to change the “Hide in menu” and other options in backend but it doesn’t help. I didn’t find any configuration to set the rootlevel page or something like that. Can you help me? Any suggestions?

I’am using:


Hey Christian

do you have a special type for the homepage? One that for example has no indexer config?


Hi Daniel,

yes i have a custom homepage element, but to avoid this problem i was changing the type to a normal page element and build the index again. Nothing changed. So i thought it might be caused by the “hide in menu” checkbox. So i disabled that option and tried again. No success.

The elment wich i’m searching is a normal Text Element (TYPO3.Neos.NodeTypes:Text) wich is found on any other page.

Is there something else i might forgot to look for?

Thanks, Christian.

If i add this Settings.yaml part:

type: string
include_in_all: true
indexing: ‘${value}’

The text node was found but not the document node from the homepage. so fluid cannot generate links … of course. but why elasticsearch is not indexing the homepage generally… it has the same nodetype as other pages. must be found … TYPO3.Neos.NodeTypes:Page

I installed a fresh “demo package” from https://www.neos.io/download-and-extend.html and only added elasticsearch from https://github.com/Flowpack/Flowpack.ElasticSearch.ContentRepositoryAdaptor as said under “Installation” and i have the same issue.

I add a new page “search” and put the NodeType “Flowpack.SearchPlugin:Search” into the page. then i go to frontend and search something from the homepage. for example “Imagine”

It dos not show the Homepage in the results … why?

prototype(Flowpack.SearchPlugin:Search) {
searchQuery = ${this.searchTerm ? Search.query(q(site).parent().get(0)).fulltext(this.searchTerm) : null}

was the solution.

thanks wilhelm.

Ok, this solution works only without content dimension. if i switch the language i get an error:

Argument 1 passed to TYPO3\TYPO3CR\Search\Eel\SearchHelper_Original::query() must implement interface TYPO3\TYPO3CR\Domain\Model\NodeInterface, null given

So there is a bug inside of TYPO3\TYPO3CR\Domain\Model\NodeInterface or Flowpack\ElasticSearch\ContentRepositoryAdaptor\Eel\ElasticSearchQueryBuilder

can someone help me?

does nobody had this problem before?


I work tomorrow on the ES package, and will push a PR to include the homepage in the default query. Basically currently it’s clear that we search only bellow the homepage (excluding the homepage).

1 Like