Error after fresh installation: Call to undefined function GuzzleHttp

Hi,

directly after a fresh Neos installation (and choosing the Neos Demo Site Package) the frontend crashes with this error:

Call to undefined function GuzzleHttp\Psr7\str()
Bildschirmfoto 2021-07-05 um 16.58.43

The Backend login works (despite of that the frontend preview shows the same error).

Tested locally on a PHP7.4 and on a Webserver with PHP7.3 and the same Error.

The installation method was with:
$ composer create-project neos/neos-base-distribution project

I guess you have GuzzleHttp\Psr7 Version 2 installed. They removed in this version the deprecated GuzzleHttp\Psr7\str() function.

One should use the replacements: Extracted functions to static methods by GrahamCampbell · Pull Request #345 · guzzle/psr7 (github.com)

See TASK: Replace deprecated guzzle functions with static methods by albe · Pull Request #3368 · neos/neos-development-collection (github.com)

I dont know how this all relates to another - but thats somehow the problem.

I think @aberl has the overview.

Thank you.
I managed to get it working again with downgrading the GuzzleHttp\Psr7 packet.
Just after the install I did:

$ composer require guzzlehttp/psr7 "^1.8.2"
$ composer update

This maybe just a workaround and make problems in later versions, but it works for now.

1 Like

I had the same issue with a fresh Neos Demo installation according to the official Docs.

Your workaround worked also for me, thanks @many !

i now also encountered this problem on a fresh neos.demo install ^^

Hey everyone! Sorry for the mess with this package we caused by allowing installation of 2.0 prematurely. The fixes, which avoid installing 2.0, have been merged and I tagged releases of Flow yesterday, so manually requiring “^1.8” should not be needed any more.

If you still find anything off, don’t hesitate to bring it up here or on github and tag me!

3 Likes