Error upon importing Neos.Demo package during installation


I tryied to do a fresh, clean installation of Neos 2.2.2 today. Unfortunately i failed multiple times with different configurations and spent more than 5 hours just for installing a new neos project with demo site package :frowning:

Now I need your help!

During setup process everything works fine up to step 4. Here I select the “Neos.Demo” package and head on to the next step. After 2-3 seconds a blank white page is displayed. When I reload this page the same step4-form is displayed again with the additional option to “Delete existing sites”. Again nothing (i.e. blank white page) happens.

I may skip this step to proceed to step 5. Here I get informed that everything worked well.

When I visit my frontend at http://neos.demo the following message is displayed:

Missing Homepage
Either no site has been defined, the site does not contain a homepage or the active site couldn't be determined.
#1346950755: Homepage could not be loaded. Probably you haven't imported a site yet
You might want to set the site's domain or import a new site in the setup.
Go to setup

Upon login on backend I get:

Page Not Found
Sorry, the page you requested was not found.
#1301610453: Could not resolve a route and its corresponding URI for the given parameters. This may be due to referring to a not existing package / controller / action while building a link or URI. Refer to log and check the backtrace for more details.

The execution of ./flow flow:cache:flush does not change anything at all.
When I list mit sites with ./flow site:list I get the “Neos Demo Site” with “neosdemo” as node name and “Neos.Demo” as Resources Package. My domain list with ./flow domain:list it empty (No domains available).

I tried to manually import the demo site package with ./flow site:import --package-key=Neos.Demo with no success. The table typo3_typo3cr_domain_model_nodedata contains only two rows, both for path “/” (one for workspace “live” and one for “user-peach”).

When I run ./flow node:repair I get
Could not find "/sites" root node
as second statement. All other checks pass.

What do I need to do for getting my copy of neos up and running? Thanks for any help!

Same here! :stuck_out_tongue:

I had this same error and spend hours on it. At the end, I think it is a permission problem with the Web/_Resources folder. Be sure your php script is able to read and write on it.

Hi Sebastian

Thx for your replay. Unfortunately this didn’t work for me. The permissions for this directory were already set to drwxrwxrwx+ with the right group assigned…

I will try a fresh installation, maybe it was a specific bug with 2.2.2?

Should be fixed in 2.2.3:

1 Like