ERROR while uploading images (Neos 2.12) (workaround)


When trying to upload an image, the upload fails and Neos shows this error message:

HTTP Error. for the file “someimage.png”

In the exception logs I find this line:

Previous exception: Exception #1336662898: The given resource was not an image file your choosen driver can open. The original error was: Gmagick not installed

This seems pretty straigthforward, however Graphicsmagick IS installed and the site is up and running wihout problems - i just can’t upload images! Uploading e.g. pdf-files works fine … neos just doesn’t generate thumbnails for it.

To clarify: I develop the site in a VM and when ready I move it over to the webserver, which involves all kinds of fixing symlinks and stuff. That worked just fine for Neos 1.x sites.
With Neos 2.12 I suddenly get the image upload error on the live server - the VM installation is obviously working just fine.

My guess is that even though Gmagick is installed, Neos just can’t find it.
How can I make Neos find it?


ok, I worked around the problem by changing the Imagine driver in settings.yaml to this:

driver: Gd

I then flushed the production cache and reloaded apache service:

sudo FLOW_CONTEXT=Production ./flow flow:cache:flush
sudo service apache2 reload

uploading works again. :slight_smile:

Still, I’d really like to know what went wrong with Gmagick/Imagick and how to fix it.