F:debug "hash link" not working


I am trying to fetch the logged in user’s data, but I don’t know what data is available, so I tried to debug the ${Security.account} object to see what’s in there.

// In fusion
myAccount = ${Security.account}

And then in fluid:


This results in a one-liner debug window, that has a #hashLink to some kind of identifier, but does nothing once I click it. The user I am trying to debug is a front-end user (from the package FrontendLogin). I tested this in a demo-site build to check if my project is causing this bug, but unfortunately I experienced the same behaviour in the demo site.

So, is this a known issue ? Does it have to do with security and data passed to the view being unavailable ?

Bonus question: How do I get the name / e-mail of the currently logged-in user ?

The output represent the object. If you want to output the account identifier do something like {myAccount.accountIdentifier} - you can literally access every accessible property from the Account model through Fluid

But I don’t know what properties are there to access, that’s my problem.

Also in general case (I remember I had this ‘one-liner link’ output from the debugger before), how do you debug the data in this case ? Normally I am getting a huge list of all data of the object in question, but this one-liner with the broken link doesn’t help much …

Take a look in the class (https://github.com/neos/flow/blob/master/Classes/Security/Account.php) and see the properties. It’s the same for other objects you assign.

Ah I see, that helps, thanks !

The f:debug issue is still not resolved though …