How to enable a new site package („No sites available“)


I’m having issues to enable a site package (essentialy generated by kickstart:site). Here is what I did to enable it:

Created a new Site Example.ExampleDe.

composer.json includes "type": "neos-site".

    $ cat Packages/Sites/Example.ExampleDe/composer.json
      "description": "",
      "type": "neos-site",
      "require": {
          "neos/neos": "*",
          "neos/nodetypes": "*"
      "suggest": {
          "neos/seo": "*"
      "name": "example/example-site",
        "autoload": {
          "psr-4": {
            "Example\\ExampleDe\\": "Classes/"
      "extra": {
          "neos": {
              "package-key": "Example.ExampleDe"

Reset package configuration and flush cache.

$ rm Configuration/PackageStates.php
$ ./flow flow:cache:flush

No sites :confused:

$ ./flow site:list
No sites available

/neos/administration/sites reports No sites available.

Any ideas`?

In the cli run ./flow site:import --package-key Example.ExampleDe to import the the default sites.xml or ./flow site:create --name 'example' --package-key Example.ExampleDe to create an empty site document.

Afterwards ./flow site:list should show a site.

1 Like

./flow site:create --name example --package-key Example.ExampleDe did the trick! Thanks a lot.

I assume this command creates any empty root page in the database?

Exactly: ./flow help site:create will tell you all the options