Installation help needed!

Hi! I am new to Typo3 Neos…
I want to install Typo3 neos in Windows 10 for my project.

I just followed the steps given in the “

I have PHP 7, Apache Web server , composer and mysql installed in my machine.

Is it possible to install and use Typo3 neos in windows?

When i try to run http://neos.demo/setup , i see only the index.php code instead of the setup page.

PHP code:

<?php /* * This file is part of the Neos.Flow package. * * (c) Contributors of the Neos Project - * * This package is Open Source Software. For the full copyright and license * information, please view the LICENSE file which was distributed with this * source code. */ $rootPath = isset($_SERVER['FLOW_ROOTPATH']) ? $_SERVER['FLOW_ROOTPATH'] : false; if ($rootPath === false && isset($_SERVER['REDIRECT_FLOW_ROOTPATH'])) { $rootPath = $_SERVER['REDIRECT_FLOW_ROOTPATH']; } if ($rootPath === false) { $rootPath = dirname(__FILE__) . '/../'; } elseif (substr($rootPath, -1) !== '/') { $rootPath .= '/'; } putenv ("FLOW_REWRITEURLS = 1"); putenv ("FLOW_CONTEXT = Production"); require($rootPath . 'Packages/Framework/Neos.Flow/Classes/Core/Bootstrap.php'); $context = \Neos\Flow\Core\Bootstrap::getEnvironmentConfigurationSetting('FLOW_CONTEXT') ?: 'Development'; $bootstrap = new \Neos\Flow\Core\Bootstrap($context); $bootstrap->run(); could someone please help me!! Thanks in advance. Thara.G

The output shows that your webserver isn’t interpreting PHP. It just returns the raw PHP file. This is a problem in your web server setup which has nothing to do with Neos.

To me, it has often helped to temporarily create a very simple file info.php:


and then use that as an indicator whether the webserver setup works as it should.

Regarding your setup (PHP 7 and Apache Web Server) you have two options of connecting those two together:

  • use the apache php module
  • setup php as CGI application (php-fpm)

There is lots of web resources that can help you through that.

Thanks a lot Ludwig…After successful PHP setup changes , i am able to see the setup page …
After entering the password i am getting below error.

Notice: Undefined index: enabledDrivers in D:\Users\apache\htdocs\Neos\Data\Temporary\Development\Cache\Code\Flow_Object_Classes\Neos_Imagine_AbstractImagineFactory.php line39

What should i change? Thanks in advance!!

  1. Delete the «Temporary»-folder under D:\Users\apache\htdocs\Neos\Data.
  2. Reload the page/setup-process.

Should help.

Thanks Martin for your reply.

I tried it already. but still i am getting the same error.

Thanks in advance

Sorry, I never had this particular error. And I’m not a core dev with deep understanding of the system …

But most of the time you have only to delete the «Temporary» folder for.
In Data there are also Logs and Persistent stuff like Resources, Plugins and so on.

Have looked in my file «Neos_Imagine_AbstractImagineFactory.php».
line 39 checks for enabledDrivers in settings.

Maybe some driver-problem with windows?
In the clean settings for linux/os x there will be an entry in the Configuration.Settings.yaml (written from neos-install-process)
with value pdo_mysql in

So I guess some missing driver stuff in your php-installation for db-connection.
Maybe someone in forum has experiences with windows-install. I have no experiences with windows-installation.
But could be like above: not a neos-context problem => more an general installation problem for a clean wamp-system.

For beginner sometimes a «xamp/wamp» installation package is a good first-step.
(Sometimes but not). Depends on your general skills/experiences.

Maybe you could find some information in the phpinfo()?!

In phpinfo() there should be an entry for PDO and pdo_mysql should be enabled I guess:

Maybe some stuff like here:

But as I said: I’m not an windows-user…
without guarantee for :blush:

Thanks a lot Martin…!

From my phpinfo(), i saw PDO and pdo_mysql are enabled.

Can someone please help me out in this…

Notice: Undefined index: enabledDrivers

Problem identified in the setup. Will fix ASAP.


Hi Christian,

I’ve got the same Issue on Ubuntu 17.10:

PHP 7.1.11-0ubuntu0.17.10.1 (cli) (built: Nov  1 2017 16:30:52) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.1.11-0ubuntu0.17.10.1, Copyright (c) 1999-2017, by Zend Technologies

I had a previous Version (guess 3.0) up and running, so I knew Gd and Imagick are OK.
After hacking around some time, I put a return statement on line 38, just before the exeption is thrown.
So I could finish the setup successfully.
While debugging with print_t(), I saw that the keys of the array

`$settings[‘enabledDrivers’] come out like

[keyName] => value, instead of “keyName” => value.


Hi Thara,

some time ago I’ve tried to install Neos on Win 8.1. (Xampp …)
It’s a pain in the ass!
If you are very good, you will have it running after many long debugging sessions.
Then you will end up with an installation, where you never know, why it gives you errors:
Is it your fusion code or your buggy installation.
Neos and Flow use the permission system of Unix an Symlinks. Windows don’t have it.

So I gave it up. Now I’m using Ubuntu Linux. For me that’s perfect. I’ve installed it as a second OS on my comuter. It’s free and it rock’s.
You can try Ubuntu as a “live System”, without installing it. If you are happy with it, install it.
Most of the developers here use apple computers. That is a good choice if you have one.


Hi Klaus,

Thanks a lot for your suggestions!! I will try for that…


Hi Klaus,

I tried installing Neos setup with Bitnami.
After setup login page ,i got below error

“Could not connect to database
An exception occured in driver: Access denied for user ‘bn_neos’@‘localhost’ (using password: YES)”

any idea?? i tried to uninstalling Bitnami and installed it again…same problem exists…

Thanks in advance !!

Hi Thara,

I stepped into that trap too.
Got running with Bitnami (a year ago, or so), but the settings page was blank, and there was no possibility to access Neos using a terminal. You have to do a lot of things on the command line. So Bitnamy was a nogo at the time.
I recomend you Linux as a second OS, or in virtualBox.


Note: The error about enabledDrivers has been hotfixed for now and a composer update should install neos/imagine 3.0.4 which works fine.

1 Like

during neos 3.3.3 demo install, the error is gone!
Thank you :+1:

Very good. Thanks Christian.
After composer update, the error is gone. Setup works like expected.
This was a real show stopper!

So, back to work …