Installing on older versions of PHP

My host only has PHP 5.6.32, I would like to use Neos+Flow but am unsure how to install using an older version. I will initially install locally on a WAMP server with 5.6.32 installed and then deploy from there.

Any ideas?

Sorry to be harsh, but find a different host. 5.6 is a “Security fixes” only and Neos/Flow requires at least PHP 7

There is used a bunch of PHP 7 methods, syntax and functionality, that is not found in the PHP 5.6 package - so for that reason, you will not be able to install it at all

So you can’t install an OLDER version of Flow and Neos? I am able to do that with several other CMS’s

I understand about the PHP version, however, this site is for a non-profit that gets their hosting for free and I have no option to upgrade the PHP version or move hosts.

Hi Eddie,

It is possible to install Neos 2.3 (which only requires PHP 5.5+), however it would be highly discouraged and a terrible investment for the future as that version stop receiving bug fixes in August this year and security fixes a year later. Additionally the version is far from as good as the current ones.

The time spent upgrading at some point far outweighs any costs saved on free hosting unless the development time is free as well.

Just my 2 cents

1 Like

Hi Eddie!

Try out They have a flexible price model. You decide what you want to pay for.
This should not be advertising for my favorite hoster, just help.