Major problem with workspace

Hi there,

facing a major issue and can’t find the root - driving me nuts.

There is a workspace where 4 employees are editing content. I did publish the changes regulary without any big issues - went on holidays for a week and now I am getting:

kiste@dedi3585:/usr/www/users/kiste/neos$ FLOW_CONTEXT=Production ./flow workspace:publish relaunch-3szjw

The workspace relaunch-3szjw contains 5168 unpublished nodes.

Call to undefined method Neos\Flow\Cli\CommandRequestHandler::getHttpRequest()

  Type: Error
  File: Data/Temporary/Production/Cache/Code/Flow_Object_Classes/Neos_RedirectHandl
  Line: 503

Using the Workspaces GUI showes me the Button “Überprüfen” and the system says Ergänzungen 1397, Änderungen 2763, Entferungen 424 when I hover over the “Änderungen” Col. Clicking the button leads to

Application Error
The Flow application could not be launched.

I did flushed all caches, tried to change the context from Development to Production, updated to the latest NEOS release, gave PHP more RAM. Always hitting the same error.

Any further suggestions I can try or anything I can do to save the situation?
Kind of desperate at the moment …


After adding

      enableRemovedNodeRedirect: false
      enableAutomaticRedirects: false

to the configuration to disable the service to add automatic redirects I was able to publish the changes made to the workspace.

The workspace relaunch-3szjw contains 5177 unpublished nodes.
Published all nodes in workspace relaunch-3szjw to workspace live

The NodeRedirectService uses the Method getHttpRequest which is marked as deprecated? Maybe thats the root of the problem?

if (method_exists(ActionRequest::class, 'fromHttpRequest')) {
        // From Flow 6+ we have to use a static method to create an ActionRequest. Earlier versions use the constructor.
        $actionRequest = ActionRequest::fromHttpRequest($requestHandler->getHttpRequest());
    } else {
        // This can be cleaned up when this package in a future release only support Flow 6+.
        $actionRequest = new ActionRequest($requestHandler->getHttpRequest());


the mentioned code of the NodeRedirectService it’s adapted to work with older and newer Neos versions, so this is not the source of your problem. See the code comments.

Do you have no entries in any log file that correlate to the time of your error?

Hi Sebastian,

thank you for your reply. Using the GUI nothing is logged - only the “Application Error
The Flow application could not be launched.”-Message was shown.

Using the CLI to publish the workspace, threw the above shown exception indicating a problem (direct or indirect) with the NodeRedirectService. While I was trying to understand the code I did see that the service can be disabled by configuration - so I did - and was able to publish the workspace.

I am with you that the root of the error is maybe somewhere else - I was not able to find it.