Neos 3.x and mittwald-flow/symlink-publishing

I was using symlink-publishing in Neos 2.3.x. Have upgrade a project to Neos 3.0.
Symlink-publishing doesn’t work with Flow 4.0/Neos 3.
with Flow >=3.0.2 and stop working with Flow 4.0.

Is the symlink stumbling solved in Flow / Neos by itself?

I think it was finally merged into Flow, but would have to search myself…

You can now do it like this:

But don’t use the TYPO3 namespace pls if you do use it for a 3.0 installation

First I got some error throwing: something about «not matching target in localWebDirectoryPersistentResourcesTarget»

Now, with changed target and the «ResourceManagement» in original, it throws no error.
Here the code for using in Neos 3.0.x :

          target: 'Neos\Flow\ResourceManagement\Target\FileSystemSymlinkTarget'
            relativeSymlinks: TRUE
            subdivideHashPathSegment: TRUE
          target: 'Neos\Flow\ResourceManagement\Target\FileSystemSymlinkTarget'
            relativeSymlinks: TRUE

Hope the Procedere like written in in from is still the same (the right one):

1. include the code above into Settings.yaml
2. delete all absolute referenced symlinks, etc., from the _Resources folder:
rm -rf Web/_Resources
3. execute: ./flow resource:publish

In my local environment it worked, will try also on public server next days …

I’ve updated my Gist accordingly.
I’m not yet using Flow 4.x which is the reason it wasn’t correct initially.

Thank you david,
I’ve seen the revision before the post above. Now everything «with symlink» looks like it is running smoothly.

Hope instruction and code above are right.