Neos as Headless CMS

Great Help.
Really Thanks Dmriti & Markus for help.

I install the graphQL in the package and can see the UI too.

I am afraid, how to get list of the ready-made api so I could used.
Would you please where I can get the all list of ready-made api.

Pawan Kumar

I’m sorry I’ve never used it myself, so don’t know what is your exact problem It seems there’s some server-side error (you can check the Flow logs to see what’s up).
Perhaps @bwaidelich could give you a hand?

It is fine ,you really helped me to understand the things clearly.

Would someone please help me on that about how to get all those ready-made api endpoints so I could use through the GraphQL

with GraphQL there is only one endpoint. The power is in the query language itself
Have a look at “Introspection” to learn how to discover a service’s abilities (schema)

Thanks for the reply.

Still i am getting the error when hitting the uel /neos/graphql.
Please find the attached image,Would anyone please help us in this

Which query did you enter? It looks like you didn’t write a query, yet or sent an empty one. I recommend starting with an instrospection query as mentioned above.


I used the below query and still showing the same issue.

Even tried to run with curl command too ,showing the error

please find the attached screenshot for the same

Would someone please help in this?

The error most likely indicates that there is an Exception thrown. Check Data/Logs/Exceptions for more detais or bring up the development console of chrome and check the network tab

Thanks @stolle for help.

There is no error in Data/Logs folder but yes in chrome console ,below is the issue

However I checked with 4.2 and 4.3 version too,same issue occurs,didn’t do any other configuration, just run the below command

composer require wwwision/neos-graphql

Do I need to make some other changes for the same too.

Below might be the root cause of that issue,Please find the attached file

Please help .

I’m wondering of you followed the installation guide in the corresponding graphql packages ?

It tells that you have to include the routes - and when you get HTML in return, it seems like to didn’t do that

Hi Soren,

Thanks for the reply.
I just followed the below link where it is mentioned after run the composer require wwwision/neos-graphql.
We can directly invoke the /neos/graphql

Even In the same concern ,above mentioned that there is already ready-made api.
We can consume easily them.

The link which you shared,I think is for when we want to customized or add new things to that.
Since graphql has been called through the /test url
Please correct me if i am wrong.

The link i gave you is for the actual GraphQL package - the one you include is a adapter to Neos.

In the link I gave you, the installation instruction reads

And, lastly, activate the corresponding routes:


            'endpoint': 'test'

and you mostlike don’t need the variables part.

At least try and see if it solves your issue. And if it does, please submit a PR to the Neos GraphQL package that explains that needed installation setup

So, what’s the acutal respons of your request? If you click preview instead of headers on your latest screenshot you should see the error message. “Unexpected token < in …” just inidicates that graphql playground could not parse the response to json. As you pointed out it’s text/html. And in that request the error is printed out.

Thanks @stolle for helping.

Yes,Clicking on Preview or Response Both show “Failed to show the response Data”.
Please find below attached file.

And in the below files it get failed.


Did you end up completely ignoring the question if you included the routes from the actual GraphQL package?

I kindly ask you to give feedback on the suggestion

You’re not logged in and not sending the credentials. That’s why it redirects you to /login from /neos.

Hi @pawankct91 did you find any solution of this problem because i am also facing the same one ??

@ pradhyumn_atcs Thanks for reaching out to me.

I had solved this long back and now I am into the different account where leveraging the other framework.
you may please contact me online I can help you on this