Neos on windows not officialy supported?

Got this error on setup

#1416244515: Could not publish “D:/Neos/Packages/Framework/TYPO3.Fluid/Resources/Public” into resource publishing target “localWebDirectoryStaticResourcesTarget” because the source directory could not be symlinked at target location.
TYPO3\Flow\Resource\Target\Exception thrown in file
D:\Neos\Data\Temporary\Development\Cache\Code\Flow_Object_Classes\TYPO3_Flow_Resource_Target_FileSystemSymlinkTarget.php in line 140.
Reference code: 2016120708554475124f

Symlink is kind of a linux thing. And linux setup run with no probl. But I need from time to time to work on windows :frowning:

Edited from the TYPO3 wiki:

Flow Framework uses symbolic links to make public resources available to the browser without needing to copy them to an accessible directory. Unfortunately Windows usually requires a user with privileged rights for that, so you might get errors when trying to create a symlink via PHP.

To get the creation of symbolic links work (only Windows Vista and above), open the local policy editor secpol.msc and locate Security Settings > Local Policies > User Rights Management > Create symbolic links and grant this permission to the appropriate group. You can assign “Everybody”, because there is no reason why a non-admin should not be allowed to create symbolic links IF he has write permission anyway.

After changing the permissions, you need to reboot.

If changing permissions is not an option for you, creation of symlinks can be replaced with copying by changing the strategy:

          mirrorMode: copy
1 Like

I on win 10. Can’t find any of those Local Policies. Strange.

Ghh. It’s not an option for Home version.

I can’t find “mirrorMode: copy” and do not understand from docs where to edit that, can u help?

Over that! Now is this :frowning:

Fatal error: Doctrine\Common\Proxy\AbstractProxyFactory::getProxyDefinition(): Failed opening required ‘D:/Neos/Data/Temporary/Development/Doctrine/Proxies__CG__TYPO3TYPO3CRDomainModelNodeData.php’ (include_path=‘D:\Soft\XAMPP\php\PEAR’) in D:\Neos\Packages\Libraries\doctrine\common\lib\Doctrine\Common\Proxy\AbstractProxyFactory.php on line 209

Did you run xampp with administrator rights ?
I’m using Neos on window 10 and as i see, it work nice.

Can’t help you with your Windows issues directly, but I know a lot of people are successful with running Neos via on windows. That would surely be a better way to do it. If you decide to try it out, I think @FloWeiss might be able to help out.

I’ve tried Neos and Flow on Windows a long time ago (when Flow was called FLOW3 ;-)).
It worked but performance is, of course, a lot better on Mac OS X or Docker.

I managed to run it :wink:

  1. Installed some 3rd party software, that enabled privacy policy for my WIN.
  2. I run xampp with admin rights.
  3. Started all installation from starch.

And it worked

1 Like

Yeah. I figured out that already. But thanks. And yes it the key factor.

From @aberl on Slack:

To solve this issue you need to open a Commandline with Admin privileges once (Win+R → “cmd” → Shift+Rightclick → “Run as Administrator”), go to your flow root folder and run flow cache:warmup . This will lead to all symlinks be created with the required admin privileges. Afterwards you can continue to do all further work with a normal non-elevated command line, at least until you install/de-install a package that has public resources and hence needs to update the symlinks.
I can only recommend to do all dev related work in Windows 10+ through WSL2 though.