No package for s3:connect

I want to publish my Neos CMS resources to AWS S3 and I have seen the tutorial from Robert.
But I got in trouble. When I try to run the command as below, I got an error log told me there was no command “s3:connect”. Is my Neos lack of packages? Could please help me solve this issue? Thanks a lot.

Hi Lewis,

it looks like the package hasn’t been installed correctly and thus is not detected by Flow / Neos. First thing you should try is running ./flow package:list and check if the Flownative.Aws.S3 package is listed.

If it’s not listed, please give us some more information about how you installed the package. Best practice (and the only supported way) is to add it to your Composer manifest (composer.json), for example with composer require flownative/aws-s3@beta. You might want to run composer update to make sure that all packages are up to date.

1 Like

Hello Robert,
First, thanks for your reply.
I have checked with command “./flow package:list” and there was no package Flownative.Aws.S3.
I installed Neos using the way of and the commands are below:
#1. curl -s | php
#2. php /path/to/composer.phar create-project --no-dev typo3/neos-base-distribution Neos-2.0
BTW, I got the log below when I run the command #2.

I checked them online and somebody told me they do not matter. Did I get the errer info?
Thanks a lot.

Hi Robert,
After I run the command composer update, I have got the package Flownative.Aws.S3 .Thanks a lot!

1 Like