PHP Version Error


(Muhammad Tashfeen) #1

The server is already running the neos live site and I created a staging domain and moved the project to that staging domain as well. The staging site gives me the error “Flow requires PHP version 7.0.0 or higher but your installed version is currently 5.6.34. (Error #1172215790)”.
What did I do wrong here ? It should work as other project is working as well. The flow command also works without any errors.


(Christian Müller) #2

You somehow, somewhere must have a 5.6 php version installed, maybe your web server is running php 5.6 ?


(Muhammad Tashfeen) #3

Yes the global version installed is PHP 5.6 but there are two NEOS projects and one is working fine. Which means somewhere inside the Neos it points to the right PHP version directly. My question is that is there anywhere inside NEOS to point to the php version it should use installed in ‘usr/bin/local/php7.1’ ?


(Christoph Köppel) #4

Could it be there in Settings ?
You would override this in your ‘SiteSettings’ …

phpBinaryPathAndFilename
in


(Muhammad Tashfeen) #5

Yes there is and I have already set it up correctly to point to the right binary. But still the same error exists.


(Christian Müller) #6

Where do you see that error exactly? command line? Browser?


(Muhammad Tashfeen) #7

Browser. In command line the flow command runs perfectly.


(Christian Müller) #8

Then your web server for that project runs PHP 5.6 apparently, that’s nothing you can fix in Neos, you need to change your server configuration.


(Muhammad Tashfeen) #9

Okay then I need to talk with the tech support. Thank you for the quick reply Christian. I really appreciate it.