PHP Version Error

The server is already running the neos live site and I created a staging domain and moved the project to that staging domain as well. The staging site gives me the error “Flow requires PHP version 7.0.0 or higher but your installed version is currently 5.6.34. (Error #1172215790)”.
What did I do wrong here ? It should work as other project is working as well. The flow command also works without any errors.

You somehow, somewhere must have a 5.6 php version installed, maybe your web server is running php 5.6 ?

Yes the global version installed is PHP 5.6 but there are two NEOS projects and one is working fine. Which means somewhere inside the Neos it points to the right PHP version directly. My question is that is there anywhere inside NEOS to point to the php version it should use installed in ‘usr/bin/local/php7.1’ ?

Could it be there in Settings ?
You would override this in your ‘SiteSettings’ …


Yes there is and I have already set it up correctly to point to the right binary. But still the same error exists.

Where do you see that error exactly? command line? Browser?

Browser. In command line the flow command runs perfectly.

Then your web server for that project runs PHP 5.6 apparently, that’s nothing you can fix in Neos, you need to change your server configuration.

Okay then I need to talk with the tech support. Thank you for the quick reply Christian. I really appreciate it.