TL;DR: Do you agree with the short form as (best) practice?
we’re currently making some good progress with the Event-Sourced Content Repository (see Weekly ESCR Talk - #19 by bwaidelich) and will soon go over some fine tuning of things that are hard to change afterwards (event payload, class names, …).
One thing we stumbled upon is the many “…Identifiers” that are quite hard to read.
Sebastian and me (and you?) would like to deviate from our CGL in that specific case and rename “*Identifier” to “*Id” because it is much easier to grasp.
(OK, that example is a little extreme, but it works for
$someRepository->find(ProductId $id) too.