[Semi Solved]All-inkl and neos

Hello Guys,
i try to install Neos on all-inkl. But i have a bit trouble. I come in the setup window and i get this error:
The specified path to your PHP binary (see Configuration/Settings.yaml) points to a PHP binary with the version “5.6.25-nmm1”. This is not compatible to the version that is currently running (“7.0.10-nmm1”).

So i have tried to change the path in the Flow config on “phpBinaryPathAndFilename: ‘/usr/bin/php70’” but it dosent work(i have cleared the cache), but the binary seems to be there if i look on the server with ssh. Any idea?

//Tweak Solution
Set the domain(in Kas) back to php 5.6, then install neos and after that set it back to php 7. Works for me, but i dont know if that will create problems in the future .

Did the error appear in cli-mode? In that case make sure to call the ./flow with the same php as Webserver and the binary specified in your configuration.

If you do’my specify the binary the ./flow php has a shebang line of ‘#!/usr/bin/env php’ and i assume this is wrong in your case.

Regards Martin

I have same problem too. How to solve it.

There are three php entrypoints that have to use the same php.

  1. The Webserver … when .php files are executed.
  2. The cli … when a ./flow command is executed internally the php cli command is executed you can check this vis php -v on the cli and you can also call ./flow with a specific php like this php7.0 ./flow help
  3. The php-binary that flow uses internally for proxy class compiling. This is the one you set via phpBinaryPathAndFilename

Usually all three point to the same php but if you have multiple php-versions on your server you have to make sure that flow uses the same php in all execution pathes.

1 Like

I use all-inkl as well. To make it work, you need the following setting. This makes web and CLI use PHP 7.0. 7.1 should work as well of course. Also, ensure that your site runs in Production context (I manually modified Web/index.php, but that’s a rather “dirty” way - however it’s a small private site so for me that’s fine).

      phpBinaryPathAndFilename: '/usr/bin/php70'

These days I have begun to work on a Flow Project and i had the same problem again. Cli was on php 5.6 and i need php 7. I tried to change the binary path and call ./flow with php70 but nothing works. So i send a message to the support and they told me that you can choose on wich kind of server your package is running. I said i need php7 also for the cli and they set my package(With all the accounts,ftp data and mysql databases) on a server with php 7. Now all is working fine :D. Maybe this will help someone :wink:

1 Like

If some one has the same Problem on a Hetzner server, the solution with phpBinaryPathAndFilename in the Settings.yaml works fine. :slight_smile: