Setting up Neos with XAMPP

Hi everyone,
I am trying to setup Neos Skeleton for Windows 10 Home, following the XAMPP guide.

In step 4 I am told to run the following command:
composer create-project neos/neos-base-distribution mySite

After downloading and installing around 150 files, cmd showed a lot (presumably also ca 150) of the lines on the top of the following screenshot (…postPackageUpdateAndInstall)
When finished, the error message below shows up, with the comment “System can not find the given path”.

Do you know how to fix this issue? There are some forum entries online when searching for the code 1355480641, but none of the ones I looked at seemed to help.

Thanks a lot in advance!

Hi this might be not a real problem.
the composer.json of the base distribution declares this line:
"post-create-project-cmd": "./flow welcome",
this should be just a convenient feature - eg it helps you to get started.
It could be that its not working if you dont have ./flow in your current working directory because youre using xammp.

if you remove this line youre good to go. (as it is not mandatory)

I encountered the same problem as Phil. How do I remove this line before creating the project? Composer.json is only created after the error, and I cannot re-run project creation into the same folder.

you can clone (and checkout the correct branch) of manually and edit the composer.json :wink:

The problem is that your flow can’t find your php.exe.
Navigate to mySite\Configuration and copy the Settings.yaml.example to Settings.yaml
Then uncomment the lines

      phpBinaryPathAndFilename: 'PATH_TO_YOUR_PHP/php.exe'

and set the right path to your php.exe
After that navigate to mySite-Directory an run
flow welcome