[SOLVED] Can't install packages?

Hello everybody,

im new to Neos and wanted to get some packages for my website. If I execute composer require packageName the installation will success, and the package itself will display in my composer.json, but it won’t show up in the actual Neos backend.

Im executing it in the composer.json, which is in the same directory with the flow files. Is that right?

Is there something im missing?

Thanks in advance and sorry if the question might be stupid:)

Hi Lukas, welcome to the Neos community!

Which package did you install and where did you check that it’s installed?

You should run composer commands in the project root where the main composer.json is.

With „./flow package:list“ you can also confirm if it’s there.

Hello Sebstian and thanks for the reply,

I tried to install the dl/gallery package (but it won’t work with any other package either). If I run your command, the package will also show up.

I also tried to clear the cache, update all packages and turning Neos off and on again (haha)

So everythings seems to be working. But it still won’t show up in the backend.


Hey Lukas,
how do you expect this package showing up in the backend?
These two packages both offer a new node type, which can be added into a content collection on a page. There is no additional backend module involved.

Hey Daniel,

I expect to see the package in the “Package Management” section in Neos, but it isn’t there. Also, I can’t find it in here:

Or am I missing something?

Okay I’m sorry. Didn’t read the docs properly.

I’m using the docker setup and forgot to map the plugins directory in the docker-compose.yml.

After mapping the dir & building the image again, it worked:)

1 Like