[solved] Can't remove or install additional packages via composer


(Frank Mittendorf) #1

Hello all!

On my existing application I can not remove packages or install new packages.

Her is what I get by tring to i.e. remove"neos/welcome" (install delivers same error msgs):

Your requirements could not be resolved to an installable set of packages.`  Problem 1
    - The requested package phpunit/phpunit == 5.4.8.0 could not be found.
  Problem 2
    - Conclusion: don't install neos/flow 4.3.3
    - Conclusion: don't install neos/flow 4.3.2
    - Conclusion: remove neos/flow 4.3.1
    - Installation request for neos/behat dev-master -> satisfiable by neos/behat[dev-master].
    - neos/behat dev-master requires neos/flow * -> satisfiable by neos/flow[4.3.1, 4.3.0, 4.3.2, 4.3.3].
    - Conclusion: don't install neos/flow 4.3.1
    - Conclusion: don't install neos/utility-unicode 3.3.3
    - neos/flow 4.3.0 requires neos/utility-unicode ~4.3.0 -> satisfiable by neos/utility-unicode[4.3.1, 4.3.0, 4.3.2, 4.3.3].
    - Can only install one of: neos/utility-unicode[3.3.3, 4.3.1].
    - Can only install one of: neos/utility-unicode[4.3.0, 3.3.3].
    - Can only install one of: neos/utility-unicode[4.3.1, 3.3.3].
    - Can only install one of: neos/utility-unicode[4.3.2, 3.3.3].
    - Can only install one of: neos/utility-unicode[4.3.3, 3.3.3].
    - Installation request for neos/utility-unicode == 3.3.3.0 -> satisfiable by neos/utility-unicode[3.3.3].

I’ve looked on pagist: phpunit 5.4.8.0 is available there…

How can I fix it? Some ideas?
Thx!


(Max Strübing) #2

5.4.8.0 isn’t a valid semantic version release number.
Could you give further information like your complete composer.json file?

Maybe a composer clear-cache could help?


(Frank Mittendorf) #3

Hey Max,
thank your reply! “clear cache” does not help :frowning:

Here is my composer.json . Can’t see odd things there, but maybe you can…

{
"name": "neos/flow-base-distribution",
"description": "Flow Base Distribution",
"license": "MIT",
"support": {
    "email": "hello@neos.io",
    "slack": "http://slack.neos.io/",
    "forum": "https://discuss.neos.io/",
    "wiki": "https://discuss.neos.io/c/the-neos-project/project-documentation",
    "issues": "https://github.com/neos/flow-development-collection/issues",
    "docs": "https://flowframework.readthedocs.io/",
    "source": "https://github.com/neos/flow-base-distribution"
},
"config": {
    "vendor-dir": "Packages/Libraries",
    "bin-dir": "bin"
},
"require": {
    "neos/flow": "~4.3.0",
    "neos/welcome": "~4.3.0"
},
"require-dev": {
    "neos/kickstarter": "~4.3.0",
    "neos/buildessentials": "~4.3.0",
    "neos/behat": "dev-master",
    "phpunit/phpunit": "~6.0.0",
    "mikey179/vfsstream": "~1.6"
},
"replace": {
    "typo3/flow-base-distribution": "self.version"
},
"suggest": {
    "ext-pdo_sqlite": "For running functional tests out-of-the-box this is required"
},
"scripts": {
    "post-update-cmd": "Neos\\Flow\\Composer\\InstallerScripts::postUpdateAndInstall",
    "post-install-cmd": "Neos\\Flow\\Composer\\InstallerScripts::postUpdateAndInstall",
    "post-package-update": "Neos\\Flow\\Composer\\InstallerScripts::postPackageUpdateAndInstall",
    "post-package-install": "Neos\\Flow\\Composer\\InstallerScripts::postPackageUpdateAndInstall"
}

}

Frank


(Frank Mittendorf) #4

Hello!

Maybe someone is interrested. Easiest solution ever:

composer update

helps! Shame on me!