[SOLVED] Command line "package:create" fails with exception


(Frank Mittendorf) #1

Hello *!

Today I started a new flow project (my sevens in fact, but the first with flow 5).
I did a standard installation from command line as every time.

composer create-project --keep-vcs neos/flow-base-distribution .
sudo ./flow core:setfilepermissions mexo www-data www-data

I set up a vhost, created a db, build config by “Settings.yaml” and so on.
Call the project in browser gives expected “welcome to flow” screen.

But command

./flow package:create mexo.project

fails with

Warning: Invalid argument supplied for foreach() in Packages/Framework/Neos.Flow/Classes/Package/PackageManager.php line 346

“kickstart:package” fails with same exception.

I did a

./flow flow:package:rescan

but without any success…

As I remember, this procedure always went well earlier.
Does anyone have an idea what’s going wrong?

Regards, mexona

Seems related to Problem with Neos 4.2 when creating new package? -> Reply from Daniel Lienert?


(Daniel Lienert) #2

Hey @mexoona,

Yep it should be the same issue, which is fixed but not releases yet. I hope to find the time to day to release it.


(Martin Ficzel) #3

@mexoona the package:create in the current state in Flow 5.2 expects a key repositories in the composer file which may be an array or an object (the pr below fixes that) by adding the following line to your composer.json package:create should work as expected. Offcourse test and feedback for the pr below is also very welcome.

"repositories": {}

@daniellienert please check this pr https://github.com/neos/flow-development-collection/pull/1492, it should address this issue.


[SOLVED] Kickstarter broke. How to workaround?
(Frank Mittendorf) #4

Hey Martin!

Adding mentioned lines to composer.json fixes the problem indeed.
Thank you very much!

Frank