[SOLVED] "Declaration of AbstractViewHelper::registerArgument" error on Neos setup

I have tried the following setup options and always end up with a similar error message, which breaks the setup procedure:

  • Docker and Docker-Compose Setup (Mac OS)
  • Simple Setup (Mac OS)
  • Manual Setup with a web server (Mac OS)
  • Docker Setup using DDEV and Docker (Mac OS)

The error message (500 Internal Server Error) is like so:
Warning: Declaration of Neos\FluidAdaptor\Core\ViewHelper\AbstractViewHelper::registerArgument($name, $type, $description, $required = false, $defaultValue = NULL) should be compatible with TYPO3Fluid\Fluid\Core\ViewHelper\AbstractViewHelper::registerArgument($name, $type, $description, $required = false, $defaultValue = NULL, $escape = NULL) in …/www/neos-example/Packages/Framework/Neos.FluidAdaptor/Classes/Core/ViewHelper/AbstractViewHelper.php line 28

Type: Neos\Flow\Error\Exception
Code: 1
File: Packages/Framework/Neos.Flow/Classes/Error/ErrorHandler.php
Line: 81

Any advice would be very helpful!emphasized text

It was due to a changed signature in a method of Fluid

But it was solved togehter with Claus Due and should soon be released.

Add this to line to your root composer.json require section

"typo3fluid/fluid": "2.6.9",

so you pin to the former version of Fluid, and then you can remove that line, when the next version of Flow is released :slight_smile:

I renamed your thread to help others searching for a similar issue

The issue is solved, many thanks for the quick response!