[SOLVED] Failed to download imagine/imagine during installation

Hi everyone,

I couldn’t find any similar topic so I will create a new one.

I have been using NEOS 2.3 LTS for a while now and have never had any issues. However, I wanted to start with a new and clean installation of NEOS 3.1 now to get used to the new version and the new naming. Unfortunately, I have a “big” issue that’s keeping me from downloading and installing the files.

I used the standard command for installing NEOS:
php …/composer/composer.phar create-project --no-dev neos/neos-base-distribution .

Both the composer and NEOS were “installed” using PHP7.1.

As you can see in the screenshot, there is an issue with the imagine/imagine. No matter how I try the installation, using different php- and composer-versions, it simply won’t download/work. I suspect that this is an issue with github but can’t really believe this.

Is this an issue with github or with NEOS?

Does anyone have an idea of how I could solve this? Any help is much appreciated and many thanks in advance to everyone!


Did you retry by now? I guess it was just a short term outtage…

Hi Christian,

Yes indeed I tried it several times during the last days, the last time maybe 2 hours ago. It always got stuck at imagine/imagine. I fear this has nothing to do with github.

I also corresponded with my hoster and they said will have a look into it. But I have doubt they will find something. I don’t know but my gut feeling is that this has something to do with Neos and the composer but I can’t really explain this feeling. Is there maybe a version of composer that’s famose for causing issues with Neos, although I must say that I have the newest one.

I’m really stuck hear. Do you have any ideas?


I have no real advice, I just cleared my composer caches and tried myself. Worked just fine. So for now I would really say it must be related to the server in a way. Maybe that specific IP of github has a problem or something about the imagine url sets something off…

Hmm, too bad.

I’ll wait for the hoster to come back to me and see if they have an advice. If not, I really need to start from scratch with everything to really eliminate every possible problem.

But thanks for your help! I’ll keep you updated.

Hi Christian,

It literally took ages to find the error but at the end of the day my hoster found it. Long story short:

The data center was under an attack for the last few days. During this attack a DDoS protection rule was triggered causing timeouts all over the place (incl. composer).

My hoster had to analyze this in collaboration with the experts of the data center. But as I said they found the error, fixed it and now I can install Neos again without any problems. :slight_smile:

Thanks for the help again!