[SOLVED] How to activate LinkEditor/ckeditor5 in 4.1?


(Daniel Bischoff) #1

Hey there!

I made a fresh installation of Neos 4.1 and wanted to activate ckeditor5 in my new package.
I did this as described here (because i wasn’t sure if its already default :sweat_smile:)

What i see is the new Table-Editor and thats cool, but i cant edit links to give them a title and so on.

image

Did i miss something?


(Aske Ertmann) #2

Can confirm, have the same issue.


(Dmitri Pisarev) #3

Hi there!
First of all, additional link attributes are disabled by default, not to disrupt existing projects.
To enable them you should add this to your property definition:

inline:
  editorOptions:
    placeholder: i18n
    autoparagraph: true
    linking:
      anchor: true
      title: true
      relNofollow: true
      targetBlank: true
    formatting:
      strong: true
      em: true
      u: true
      sub: true
      sup: true
      del: true
      p: true
      h1: true
      h2: true
      h3: true
      h4: true
      h5: true
      h6: true
      pre: true
      underline: true
      strikethrough: true
      removeFormat: true
      left: true
      right: true
      center: true
      justify: true
      table: true
      ol: true
      ul: true
      a: true

However, currently it’s not possible to use both old Aloha format definitions and the new format, the Aloha format would be discarded. But this behavior is now fixed in master, so since the next release (which should happen quite soon), you should be able to mix the old and the new config format again.
But even better than that, there’ll be an automated migration from the old format to the new one: https://github.com/neos/neos-ui/pull/2120

Anyways, sorry for the confusion, hope this post cleared it up a bit.


(Daniel Bischoff) #4

Hi @dimaip, thank you for your explanation. neos-ui has now an update (1.3.4.).
So now i have to use your code for each node where i need the additional link attributes, right?
But is there no way to activate that globaly?

I tried to use it for Text and TextWithImage, but it did’nt work… maybe i’m just too confused :sweat_smile:

'Neos.NodeTypes:Text':
  properties:
    ui:
      inline:
        editorOptions:
          placeholder: i18n
          autoparagraph: true
          linking:
            anchor: true
            title: true
            relNofollow: true
            targetBlank: true
          formatting:
            strong: true
            em: true
            u: true
            sub: true
            sup: true
            del: true
            p: true
            h1: true
            h2: true
            h3: true
            h4: true
            h5: true
            h6: true
            pre: true
            underline: true
            strikethrough: true
            removeFormat: true
            left: true
            right: true
            center: true
            justify: true
            table: true
            ol: true
            ul: true
            a: true

(Dmitri Pisarev) #5

@shuffgy hey! I think you could set the default option for link editor like this in Settings.yaml:

Also it’s not possible to use the old and the new config formats together, but in any case, make sure you update the editor settings to the new format. There’s now an automated migratation available: ./flow core:migrate Your.PackageName


(Roland Schütz) #6

@shuffgy Did this work for you?

If so, please prefix your topic title with "[SOLVED] "


(Florian Feuerpfeil) #7

I have an equal problem. I think ckeditor5 is not enabled. I tried it with:

(Like in Description Blog CKeditor 5)
Neos:
  Neos:
    Ui:
      frontendConfiguration:
         defaultInlineEditor: ‘ckeditor5’

But nothing happend I have not all possible options to edit text in the backend.

noCKeditor5

How can I fix it?

Best regards


(Florian Feuerpfeil) #8

I figered out how to add the other editor options.

‘Neos.NodeTypes:Text’:
  properties:
    text:
        ui:
            inline:
              editor: ckeditor5
              editorOptions:
                formatting:
                  strong: true …

Fixes it for me. In the previous reply you miss the ‘text’ property.
Only the Linkeditor is still the old one.

Hope this will help the first time.