[SOLVED] Image sorting «last modified» has change after export/import

after upgrade project from Neos 2.3 to Neos 3.0 the sorting by «Last modified» in Media-Manager show’s a big mess and also loosed the «used in path» within edit-mode.

I also have export end import the project with Flow.

Would love to circumnavigate this next time:

  • Is this the normal behavior, because of upgrade?
  • Is this happen, because of export/import the project?
  • Is this happen, because of missing «symlink-publishing Package»?

Hi Martin,

You have to be a bit more specific than “show’s a big mess”. Sorting works fine in 3.0.

If you mean the order is different from before, then yes that will happen if you exported and imported instead of migrating the database, which in general is a bad way to do it as exports lose some meta data.

If you mean the images don’t display anymore, then sure it might be related to the resources not being available if there’s some problems with the way you use symlink publishing.

No idea what you mean with “used in path” within edit-mode.

Regarding the “currently the asset is not used”, that seems like a bug actually.

Hey @aertmann,
sorry for the less specific explanation.
And you are right: The sorting is working fine in 3.0, but the image-sorting is really different then in 2.3.9: like shuffle by coincidence.
Now, where I get a migrate system, I can see the different. The «sorting by last modified» is still like in 2.3.9 and much more helpful :pensive:. Great!

But the «counting usages» from 2.3.9 (printscreen down) is lost in 3.0:

My «path» was also less specific or wrong: I meant «Document and Reference». Both together is like a path to find the place where images are in usage.
For my


Usage is after the migration still missing.

Press on «Replace»

There is the wrong output «the asset is not in used…»

In current state, this is also missing after a selection of an other image > «apply» and «published life» with different pictures.

I don’t know if this has the reason (bug) because of migration. But it is not such important for my work, like the shuffled images in Media-manager.Thanks to well done migration the work is much more easy!

I have to try to use the hints from @david.sporer and @stolle. The first try gets errors because of not matching target in localWebDirectoryPersistentResourcesTarget.

Of course with Neos as root-part. I guess FileSystemSymlinkTarget will be a placeholder, but I have to figure out first.

I guess there were a lot of related difficulties: maybe missing symlink publishing or composer removed simple-search package (because no fitting with 3.0), or some other removed packages …
There were first two data-records in nodedata with something from simple-search in it, without relation. After delete of those, there were a ton of problems with missing or no matching dimensions.

At the end, after a few repeating migration-sessions, and with the working package (thanks to @christianm) the migration and all data-records are clean and no errors or missing things remained.

Somewhere between, there were also the shuffled images. And I didn’t know what was the first «reason» for a lot of question marks.
The first try for migration was semi-working with the dimension problem. After a few unpleasant trial and errors, I tried the combination with export/import, and so on …

But now, after the migration the Topic is obsolete or at least wrong titled.

I change it to «image sorting «last modified» has change after export/import». And at the end it is solved.

Only the part with «usages» is still not working. But this was not the main want of this Topic.

Sorry and thanks a lot for your help and explanation!

Hey glad it worked out.

Regarding it not showing the usages/references, I could confirm that bug so something is wrong in that area. Would you mind opening an issue on https://github.com/neos/neos-development-collection/issues? Thanks

Done :wink:!

1 Like