[SOLVED] Installing Neos (4.2) with composer not possible


(Karsten Schulze) #1

I try to install NEOS on a server of 1blu as described here :

php version:

$ php -v
PHP 7.1.7 (cli) (built: Jul 12 2017 15:42:46) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright © 1998-2017 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright © 2002-2018, by ionCube Ltd.
with Zend OPcache v7.1.7, Copyright © 1999-2017, by Zend Technologies
$ which php
/opt/php7.1.7/bin/php

When I create a new project based on the base distribution I got:

$ php Software/composer.phar create-project neos/neos-base-distribution Neos
Installing neos/neos-base-distribution (4.2.0)
  - Installing neos/neos-base-distribution (4.2.0): Loading from cache
Created project in Neos
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for neos/nodetypes 4.2.x-dev -> satisfiable by neos/nodetypes[4.2.x-dev].
    - neos/nodetypes 4.2.x-dev requires neos/content-repository 4.2.x-dev -> satisfiable by neos/content-repository[4.2.x-dev] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Installation request for neos/site-kickstarter 4.2.x-dev -> satisfiable by neos/site-kickstarter[4.2.x-dev].
    - neos/site-kickstarter 4.2.x-dev requires neos/content-repository 4.2.x-dev -> satisfiable by neos/content-repository[4.2.x-dev] but these conflict with your requirements or minimum-stability.
  Problem 3
    - neos/media-browser 4.2.0 requires neos/neos 4.2.0 -> satisfiable by neos/neos[4.2.0] but these conflict with your requirements or minimum-stability.
    - neos/neos 4.2.x-dev requires neos/media-browser ~4.2.0 -> satisfiable by neos/media-browser[4.2.0].
    - Installation request for neos/neos 4.2.x-dev -> satisfiable by neos/neos[4.2.x-dev].

Do you have any idea how can i solve it? Thanks for any hints.


(Martin Ficzel) #2

4.2 is in the process of being released. Since there are quite some packages to be released this can take a bit. Once this is done Neos 4.2 will be announced officially.

Until then use the version constraint ~4.1 for composer


(Karsten Schulze) #3

@martoro
Thanks for your fast support.
version 4.1 works - thanks