[SOLVED]Neos 3.3: The Fusion object `Neos.NodeTypes.Form:Form`does not exist

Good morning,

after upgrading to Neos 3.3 LTS I get an exception:

The Fusion object `Neos.NodeTypes.Form:Form` which you tried to inherit from does not exist. Maybe you have a typo on the right hand side of your inheritance statement for `Neos.NodeTypes:Form`.

If I try ./flow node:repair I get
Found undefined property named "formIdentifier" in "/sites/package/node-e0lhjmj30qn6l/main/node-pkdioeo6r65qi" (Neos.NodeTypes:Form)
Do you want to remove undefined node properties? (y/n)

The form is implemented like described in the docs and before upgrade it worked well.
If I try to create a new form in backend I see that there is no Form NodeType under General anymore.

Any idea?

1 Like

+1 same problem here

For the moment, you need to manually require neos/nodetypes-form in your composer file. This is a bug and will be fixed.

That works :+1:
Thank you.

Fix was merged and version tagged earlier. Should be ok with an update now or soon.

1 Like