[solved] Neos Uncought Exeption after install

Hey to all,

I’ve installed Neos on a Debian 8.2 with PHP 5.6.14 as FPM.
Installation works fine - but if I open the frontend or login to the Backend i get the following error in the error_log.

[Wed Nov 25 10:48:15.519403 2015] [proxy_fcgi:error] [pid 9062:tid 140224575239936] [client] AH01071: Got error 'PHP message: PHP Warning:  Uncaught exception 'TYPO3\\Flow\\Error\\Exception' with message 'Warning: require(/var/www/vhosts/<domain>/httpdocs/Data/Temporary/Development/Doctrine/Proxies/__CG__TYPO3FlowSecurityAccount.php): failed to open stream: No such file or directory in /var/www/vhosts/<domain>/httpdocs/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 209' in /var/www/vhosts/<domain>/httpdocs/Packages/Framework/TYPO3.Flow/Classes/TYPO3/Flow/Error/ErrorHandler.php:80\nStack trace:\n#0 /var/www/vhosts/<domain>/httpdocs/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php(209): TYPO3\\Flow\\Error\\ErrorHandler->handleError(2, 'require(/var/ww...', '/var/www/vhosts...', 209, Array)\n#1 /var/www/vhosts/<domain>/httpdocs/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php(209): Doctrine\\Common\\Proxy\\AbstractProxyFactory->getProxyDefinition()\n#2 /var/www/vhosts/neo...\nPHP message: PHP Fatal error:  Doctrine\\Common\\Proxy\\AbstractProxyFactory::getProxyDefinition(): Failed opening required '/var/www/vhosts/<domain>/httpdocs/Data/Temporary/Development/Doctrine/Proxies/__CG__TYPO3FlowSecurityAccount.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/<domain>/httpdocs/Packages/Libraries/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209\n', referer: http://<domain>/neos/login

Do you have any idea how i can fix this issue?
Can i deliver some other informations?

thanks so much

Not sure if you solved this (or gave up) in the meantime… But two things I’d check are file permissions and if simply removing the temporary files (Data/Temporary) solves that already. Sometimes it’s a smple hiccup when building caches for the very first time.

If not, please check Data/Logs/Exceptions for an exception dump caused by this error, that could contain helpful data.

Its fixed already

I’ve found the command “php_flag engine off” in one of your htaccess files.
If i comment this line, neos works fine


The issue is known and fixed in the core (https://github.com/neos/flow-development-collection/pull/137)

Currently working on new patch releases where the fix will be included

1 Like