[SOLVED] Nginx 403 Directory Listing Forbidden

Followed the manual setup guide with nginx. When I try to load the page, I get this in the nginx logs:

2021/12/08 22:59:52 [error] 26350#26350: *1 directory index of “/path/to/neos/” is forbidden, client: 192.168.2.196, server: 127.0.0.1, request: “GET / HTTP/1.1”, host: "192.168.2.27:30080

I’ve redacted the path. The permissions are set to www-data which is what nginx is running as. Flow was set to use these permissions as well.

DirectoryIndex is disabled - that good :slight_smile: But it could seem like you aren’t pointing to the Web folder, where the index.php is located.

And remember the to have rewrite rules like this (depending on how you setup nginx in your case)

location / {
  try_files $uri $uri/ /index.php$is_args$args;
}
1 Like

Ah, the root is not the project folder, it’s the Web folder. Thank you.

1 Like