[SOLVED] Privilege target not definded - 4 machines, 3 different behaviors

Hello All,
after upgrading a NEOS 2 Site to NEOS 3, I have different behaviors running the ./flow command. The installation has 3party plugins

Machine I with Ubuntu 18.04 and php 7.0.31 runs perfect
Machine II with Ubuntu 16.04 and php 7.0.30 runs perfect

Machine III with Ubuntu 17.10 and php 7.0.30 terminates with an error:

VendorName_NodeTag_TagManagement_CrudAccess", referenced in
role configuration "Neos.Neos:Administrator" is not defined!

Machine IV with Ubuntu 16.04 and php 7.0.31 terminates with an error:

VendorName.FrontEndUsers:LoginForm", referenced in 
role configuration "Neos.Flow:Everybody" is not defined!

All the 4 Versions are exactly fresh checked out & “composer install” from the same repository

Any ideas?


Can you run:

flow package:list

And then check the package ordering ? Look like some random package ordering, or some package not loaded on some machine.

And can you give us your composer version ? I remember that 1.6.x has some bug where they can skip some package “randomly”, if you use the version can you upgrade your composer to have the same version on each machine, and try a fresh install again.

Dominique, thank you very much for your support. I solved the problem with running DistributionUpgrader.phar in the 3rdParty Packages again. There were some composer.json entries left with typo3 ns, which where not rewritten during the first run of the upgrader. Now it works with composer 1.6.x and 1.7 as well.