[SOLVED] Problem with the Installer

Hello everybody. I have just found this CMS and am positively surprised at how it is built and how you are cooperating in the team.

But I noticed an error in the installation: I can only run the first 4
steps, then it logs me out automatically and I have to start from scratch.
I can not make the fifth step. According to a video, I could theoretically choose whether I want to create a
demos or not - this demo site is completely missing to my installation. (I don’t know if it matters, but I use PostgreSQL)
Everything else is fine - til now.


Hello Kal,

i usually work on mySql so i cannot test the report but it is possible that there is a problem with prostgresql and the installer.

To get around this problem you can easyly do the same as the installer from the cli in almost the same time.

Given you created a fresh neos-project based on the neos-base-distribution you can follow the following steps to get to the same results as the installer:

Step 1. Go to file Configurations/Settings.yaml and complete the db-section with the following data

# Attention: in neos-versions below neos 3.0 the following 
# configuration key has to be "TYPO3" instead of "Neos"
        driver: pdo_pgsql
        dbname: ....
        user: ....
        password: ....
        host: ....
        port: ....

Step 2. Let flow apply the db-migrations to bring the db into the expected state

./flow dorctrine:migrate

Step 3. Import a site

./flow site:import Neos.Demo

Step 4. Create an admin-user account

./flow user:create --roles Administrator admin password FirstName LastName

Now you should be able to see the demo-site and to login with the credentials you chose via /neos.

Regards, Martin

1 Like

Hi Martin. Sorry for my late answer, but I have much work to do … (there are many friends waiting for a meeting before the year ends :fearful: )

But before I get back to the Problem:
Thanks for the help. I will try it tomorrow, so I find the time. For me it was/is necessary to find out, what is wrong, instead of find a workaround (so maybe I can help you too, to find some Bugs - or to explain it better to newbies :stuck_out_tongue_winking_eye: )

Back to the Problem:
I tried with MariaDB - the same problem (seams not to be a database Problem)

I tried several times to find out, what the problem is and I can narrow down the problem:
In the fourth step, I should select a site package - I only have 1 Item to select, so I have to choose “Neos.Demo”.
After that I have to write a package name. So I wrote a fictional package name: HnC.WeihnachtsprojektOrg (Camel_case like in the example).
The third textfield is about the site name. I decided to give the hostname of the page: weihnachtsprojekt.org.
This installation is a local test installation - but I don’t think, that this is the problem.
If I go to the “next” - Button, I have to put in my password again and start from the scratch. The thing is, that the system is already configured - with one exeption: The demo site is not loadet.

If I skip the fourth step everything is fine - I get to the fifth step - without the demo site of course.

By the way:
I found 1 small issue:
SQLSTATE[42601]: Syntax error: 7 FEHLER: Syntaxfehler bei ».«
This happens (of course) when you try to name a new Database with a dot, like “test.org”. I know, that this is a user fault, but this can be a problem for newbies. There are some possible patches for that:

  1. You can explain that in a text.
  2. You can disable the “.” Character or throw an exception.
  3. You can mask it and use it as a name (e.g. Database Name “test.org”)
  4. You can use the first name as the Database name and the second as a scheme name (But you have to explain it somewhere …)
    In PostGreSQL this is not only a nice gimmick, but if you can use “schemes” this is a very big advantage (e.g. when Webhoster limits the counts of the Databases) …

And thank you very much for your Help. As I promise, I will try your commands as soon as I can.

Best regards,

Ahh now I get it. You can either select a package to import from or you can add a package key to create an empty package. I think by adding both the installer created an inconsistent state. Can you try to only select Neos.Demo.

Regards, Martin

1 Like

OK, now it works. Thanks!

But one thing: When someone want to put in his own package, he can not unselect the demo package. So he have to login after the fourth step and go through the five steps (in the fourth step he has to choose his own package)

Thank you very much.